1
$\begingroup$

I can't find an answer even tho I have solved this issue already once. For some reason when I double click .blend file it opens it in 2.79 instead of 2.83. All I remember that there are multiple ways to set this in windows 10 but I can only remember one and that doesn't work. Which is to right click the .blend and set it to open with the 2.83. There is one thread about this from 2015 but it is useless nowadays. I can't delete the 2.79 as I need it for some files that I don't want to convert to 2.8+.

$\endgroup$
  • $\begingroup$ Note that this is not really an issue with blender, but a configuration on your operating system (which you don't mention). Every OS has a list of programs to open specific files (like .doc will open with word, .mov with a video player, and so on). So instruct your OS to open .blend files with the newer version and not the old one. $\endgroup$ – susu Aug 25 at 22:37
  • $\begingroup$ That is the issue. Setting the OS to open the .blend files with blender doesn't work. It always tries to open the .blend files with 2.79 unless I drag and drop the file on top of the 2.83 desktop shortcut. $\endgroup$ – thoughtIhadaccount Aug 26 at 0:48
  • $\begingroup$ Does this answer your question? I can't open Blender 2.8 files after I save them. Because it tries to open with 2.79 $\endgroup$ – HikariTW Aug 26 at 1:00
  • $\begingroup$ I vote to reopen this question since the older question doesn't figure out what cause the bug and the answer doesn't try to fix it with a reasonable method. Although this question is most likely caused by a bug that Windows system application opening files, this question indeed happened a lot since Blender will create multiple executable on newer version installment. $\endgroup$ – HikariTW Aug 26 at 1:50
  • $\begingroup$ I think this question belongs to the superuser.com sibling site $\endgroup$ – Leander Aug 27 at 16:23
2
$\begingroup$

Seems like you encounter the dumbest design the windows registry system can potentially have. If the executable name is the same one (.blend here), it will cause some bug and not updating the table correctly.

You can make your blender 2.79 executable named as blend279.exe. This will let the register miss the original 2.79 exe and update the new value after choosing new blend file.

example below to make it "forget" 2.83 blender:

| improve this answer | |
$\endgroup$
  • $\begingroup$ I've already done this but blender still tries to open with 2.79. $\endgroup$ – thoughtIhadaccount Aug 26 at 1:09
  • $\begingroup$ @thoughtIhadaccount Oh, yeah. I forgot that annoying behavior. Sorry for the incorrect answer. I update a feasible solution now. $\endgroup$ – HikariTW Aug 26 at 1:14
  • 1
    $\begingroup$ That worked. Before renaming 2.79 I tried editing the windows register but even that did not work... thanks. $\endgroup$ – thoughtIhadaccount Aug 26 at 1:18
0
$\begingroup$

if it's not too much of a hassle, i'd uninstall blender 2.79, open the file, then direct it to blender 2.83, and then afterwards I'd download the portable version of blender 2.79 so you can just keep it as a folder on your desktop. That way, it will only open when you specifically go out to open it.

| improve this answer | |
$\endgroup$
  • $\begingroup$ There is no need to uninstall. Just change the preferences in the OS $\endgroup$ – susu Aug 25 at 22:37
  • $\begingroup$ How do you change the preferences in the OS? $\endgroup$ – thoughtIhadaccount Aug 25 at 23:45

Not the answer you're looking for? Browse other questions tagged or ask your own question.