1
$\begingroup$

When trying to export a mesh from Blender to Ogre using the blender2ogre exporter I'm getting an error I have never encountered before :

ReferenceError: StructRNA of type Mesh has been removed.

location: :-1

enter image description here

enter image description here

Through the process of elimination I've figured out the error only occurs when I export with modifiers on my mesh, in my case the edge split and armature modifiers. Has anyone experienced this error before and what steps can be taken to remedy it?

I have had a search around on google where some people have suggested it is to do with unparented bones, however when I deleted my armature and tried to export I had the same issue. If I delete the APC mesh and replace it with a simple square then export I have no issues. The error seems to be tied to the specific mesh.

$\endgroup$
4
  • $\begingroup$ so applying the modifiers solves it? You may find resistance to this kind of question here because the addon is an external addon (this doesn't mean it's a bad question, just that it's likely to affect very few people). The addon also doesn't seem to have active development over the last few months.. $\endgroup$
    – zeffii
    Jul 21 '13 at 11:18
  • $\begingroup$ @zeffii isn't it more that this is a bug report rather than a question? $\endgroup$ Jul 21 '13 at 12:34
  • $\begingroup$ I'm inclined to call it that too, but I also see no harm in suggesting to update to the latest addon revision. We can vote to close this anyway. $\endgroup$
    – zeffii
    Jul 21 '13 at 12:50
  • 2
    $\begingroup$ This question appears to be off-topic because it is about an external addon, which is not the latest revision of said addon. We can best refer author of the question to contact the addon developer for better assistance. $\endgroup$
    – zeffii
    Jul 21 '13 at 12:52
3
$\begingroup$

It could perhaps help to update your version of the Orge3D exporter from 0.58 to 0.60 from the bitbucket page. It seems the version you use (0.5.8) is written for blender 2.65 and the latest 0.6.0 version supports blender 2.66. Failing that I suggest taking steps to contact the guy who currently maintains the addon for advice.

$\endgroup$
2
  • $\begingroup$ Thanks Zeffii, upgrading to 0.6 seems to have fixed the problem, I wasn't even aware of this latest version. $\endgroup$ Jul 21 '13 at 13:42
  • $\begingroup$ Great, now at least more people can benefit from the advice to update! :) $\endgroup$
    – zeffii
    Jul 21 '13 at 14:34

Not the answer you're looking for? Browse other questions tagged or ask your own question.