1
$\begingroup$

I have an animation that is a couple of fruits falling into a blender and the blade is going very fast. But the fruits are going out of the cup. Basiccaly I want the fruits to not go out of the blender but I want the blade to still affect them at the same speed. Thanks in advance

https://drive.google.com/file/d/1DMSJfsWEGqN4sZ--Bohk-HkbFnrfQ0Mx/view?usp=sharing (ORIGINAL)

or you can use this link if not working()

EDIT:I tried increasing the steps per second but didi not work,here is that file:

https://drive.google.com/file/d/1Am6fJ9ZlgnXjnur7A5qFNkKf2z8rTPGa/view?usp=sharing (INCREASED STEP PER SECOND)

EDIT:it is going out of the side of the cup not from the top

Can you give me a good STEPS PER SECOND when you look at my file :)

$\endgroup$
2
  • $\begingroup$ sometime collisions don't work for small objects, so maybe try scaling everything up a bit? $\endgroup$ – wilks Aug 25 '20 at 15:24
  • 2
    $\begingroup$ You likely just need to increase the Steps Per Second in the Rigid Body World settings. With the steps set too small the objects will have moved through any obstacle between 'steps' and so never actually collide. $\endgroup$ – Rich Sedman Aug 25 '20 at 15:26
1
$\begingroup$

You don't mention whether the objects are simply flying out of the top of the blender or whether they are passing through the sides.

Assuming they are passing through the sides when travelling too fast, the problem is likely due to the number of Steps per Second of the simulation being too low. This results in the objects moving from one side of an obstacle to the other without actually interacting with it and the solution is to increase the Steps Per Second in the Rigid Body World settings so that they collide with the surface.

The Steps Per Second can be found within the Rigid Body World properties within the Scene properties panel :

rigid body world properties

$\endgroup$
3
  • $\begingroup$ I did that but it's still coming out(it is only now coming out of bottom, not the sides) I can send a new version with the "STEPS PER SECONDS"higher here it is: drive.google.com/file/d/1Am6fJ9ZlgnXjnur7A5qFNkKf2z8rTPGa/… $\endgroup$ – Rayyan Imam Aug 26 '20 at 12:52
  • $\begingroup$ I tried your Blend file and you’ve increased the steps to 32767 - it shouldn’t need to be that high and such high values can cause their own rounding problems that can affect the simulation. Your scene is complicated with lots of objects, none of which were colliding when I tried it. I’d suggest cutting it down or starting afresh with a much simplified scene. If the same problem occurs, can you explain how you set it up - maybe re-write your question (or create a new one) for that simplified case, explaining the setup and using pictures instead of relying on someone downloading your blend file $\endgroup$ – Rich Sedman Sep 18 '20 at 22:42
  • $\begingroup$ You might find your issue just by trying to replicate with a simpler case - or at least you’ll enable others to easily replicate it to be able to offer some help and solutions. $\endgroup$ – Rich Sedman Sep 18 '20 at 22:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.