0
$\begingroup$

Every time I apply a glass sphere around my eye, to give it the circular texture and glossiness, it creates a couple problems. The iris color changes as I put the eyeball into the glass sphere. I've tried tweaking the settings to make it more clear. The best I can do is in the material viewport, it shows the true color. But the rendered it doesn't show the true color, instead its a darker shade. I've included the pictures to show what I mean, and the node of the glass eye. The only modifiers affect the two objects are a mirror modifier that is irrelevant to the transparency properties. I've also allowed refraction and screen space reflections from the properties tab. Anything would be helpful, even if its a explanation of whether I'm doing this right or wrong (I'm just lost and confused, I don't even know if I'm doing this right.)

In the first image its viewport is in render, and the second is in material viewport. After that, I put the nodes of the glass.

enter image description here

enter image description here

enter image description here

Edit1: It's not based off the light source either, I've shined a 1000 watt light source at the eye, and it still gives off the shade.

$\endgroup$
2
  • $\begingroup$ please specify if you are using eevee or cycles. $\endgroup$
    – susu
    Aug 25 '20 at 2:53
  • $\begingroup$ Sorry, I'm using eevee. $\endgroup$ Aug 25 '20 at 3:04
2
$\begingroup$

Your node setup is not the ideal way to do glass in EEVEE (I assume that's what you're using). For proper glass, use this setup (note the highlighted Blend Modes)

GlassEye

$\endgroup$
1
  • $\begingroup$ Ah, thank you! This works way better than setting transmission to 1 and calling it. Thanks! $\endgroup$ Aug 25 '20 at 4:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.