2
$\begingroup$

I've made a mesh that has an emission shader and I'd like to hide the mesh but keep the light that it emits. Is it possible? I know it's possible in cycles. But I wish to know about EEVEE.

I've tried using the 'hide from render' ( in the outliner ) button but it doesn't work.

$\endgroup$
5
$\begingroup$

You can do it with a shader like this - This will exclude the object from visibility, but will allow the cast lights and shadows to operate. However, since you are using an emission object to cast your "light", you will need to bake the lighting from it using an Irradiance Volume, before it will show up in the render. Also - remember to set the Blend Mode to Aplha Clip.

InvisibleEmmit

Irradiance

To get the full effect, make sure to enable "bloom" in Render Properties.

Bloom

$\endgroup$
10
  • 1
    $\begingroup$ Alternatively you can Bake Indirect Light (as proposed) and after that disable the Mesh-Light object from rendering :) $\endgroup$ – vklidu Aug 24 '20 at 13:58
  • $\begingroup$ It doesn't seem to work with a mesh, unless I'm doing something wrong? [Inline Link] (imgur.com/pVWLMvl) $\endgroup$ – jzxz234 Aug 24 '20 at 14:09
  • $\begingroup$ Did you bake the lighting? If so, how big is your irradiance volume? $\endgroup$ – Christopher Bennett Aug 24 '20 at 14:15
  • $\begingroup$ Yes I baked indirect lighting.The irradiance volume is: [link] (i.imgur.com/CwgHyJp.png) Thanks $\endgroup$ – jzxz234 Aug 24 '20 at 14:28
  • 1
    $\begingroup$ I've found the problem, irradiance volumes don't work with 100% metallic materials. If I change the BSDF metallic slider to less than 100% it works but 0% metallic works the best. $\endgroup$ – jzxz234 Aug 24 '20 at 19:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.