1
$\begingroup$

When I try to render close-ups of objects as small as a few cm in Eevee, I cannot get the shadows to work properly. With Cycles, everything is fine, and I can accept the difference in look between both render engines, with the exception of the missing shadows.

Here is a comparison between both engines with the same scene:

Cycles:

Cycles render

Eevee:

Eevee render

The disk-like object is about 1.5cm in diameter. The scene is illuminated by a spot light and low level world background with a solid color.

How do I set up the shadows ideally for small scenes? Which parameters are most important when it comes to scaling, and what is their influence? Is it possible to even have shadows in Eevee in that scale?

I have read the Blender Manual - Light Settings-page but did not find a suitable set of settings with it.

$\endgroup$
  • $\begingroup$ The main thing would be to go to your spot light properties, and enable "contact shadows", You might also want to enable "ambient occlusion" in the render settings. $\endgroup$ – Christopher Bennett Aug 23 at 11:23
  • $\begingroup$ I did enable contact shadows but it had no influence. With AO enabled together with DoF I get strange horizontal band-like artefacts across the picture. I guess I have a wrong combination of all the different parameters, but without some basic understanding there are too many different combinations. $\endgroup$ – thorst Aug 23 at 11:30
  • $\begingroup$ Hmm. Try going into render properties > shadows and disabling "soft shadows" and enabling "high-bitdepth" You may also want to increase the shadow cube size. I find that these settings, in combination with contact shadows and ambient occlusion cover almost all my "shadow" needs in eevee. $\endgroup$ – Christopher Bennett Aug 23 at 11:47
  • $\begingroup$ @ChristopherBennett: If you make this an answer, I will accept it. It solved my problem. Thanks a lot! $\endgroup$ – thorst Aug 23 at 12:26
3
$\begingroup$

I use a combination of factors if I'm looking for "clean" shadows in eevee.

The first step is to ensure "Contact Shadows" are enabled for all lights that are casting shadows.

Shadow1

The next thing is to Enable "Ambient Occlusion" in the Render Properties settings, and as well, disable, "Soft Shadows", and enable "High Bitdepth". The removal of soft shadows may cause some jagged edges on your shadows - to mitigate this, you can increase the shadow cube size.

enter image description here

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.