2
$\begingroup$

I am trying to draw an eye in 2D animation. I am unable to align the centre of the pupil to the centre of the eyeball :-(

Selection to cursor (Keep offset) is aligning the side of the pupil to the 3d cursor, I want it to align the centre of the circle to the 3d cursor, what am I doing wrong?

Before move

Moving

Undesired result

$\endgroup$
1
  • 2
    $\begingroup$ are you sure the origin of the pupil is at the center of its geometry? $\endgroup$
    – moonboots
    Aug 23 '20 at 6:03
4
$\begingroup$

In Object Mode, the action Selection to cursor will move the object such that its origin is at the cursor. For your object, it's origin is not at its center, so it does not line up to the eye.

First, go into edit mode on your pupil and use Set Origin > Origin to Geometry. This will bring your origin to the center of the pupil, so when you then run Selection to Cursor, it will be properly centered.

$\endgroup$
3
  • $\begingroup$ Interesting, I tried Origin to Geometry and nothing happened. I ended up setting cursor to selected in edit mode then in object mode set origin to 3d cursor. Now when I try to move the pupil its 180cm below the whites :-( $\endgroup$
    – toddcircle
    Aug 24 '20 at 0:07
  • $\begingroup$ Does the origin show up as being in the center before you do the Origin to Geometry? (you can see the little orange dot when you select it) $\endgroup$
    – person132
    Aug 24 '20 at 18:08
  • $\begingroup$ The origin shows at 0,0,0 then I move it to geometry it moves to the centre of all geometry inside the object, I cant get it to move to the pupil geometry of the single pupil layer. $\endgroup$
    – toddcircle
    Aug 26 '20 at 0:18
1
$\begingroup$

Combine with Ctrl+J twice, to have the white and the pupil, on the same layer. Align with Transform > Align > select axes, and move the pupil to another layer. Select all layers to see all objects.

$\endgroup$
1
  • $\begingroup$ ctrl+J does nothing for me and unable to find Transform > Align > select axes $\endgroup$
    – toddcircle
    Aug 24 '20 at 0:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.