1
$\begingroup$

hope everybody's well and staying safe. Complete Blender rookie here. I was hoping for some help troubleshooting an error I encountered in Blender 2.83 while trying to assign image textures to a head model I extracted from a video game (Mass Effect 3).

So this head model has four materials: eyelashes, face, scalp, and eyes. For some reason, only one material's texture ever displays correctly -- the other three just display as a random solid color.

I've tried restarting from scratch a few times, and one thing I've noticed is that the texture always displays correctly for the first material I assign an image texture to. Any material I attempt to assign a image texture to after the first material displays as a random solid color.

Here's a screenshot of the issue, if helpful. In this instance, I assigned a texture to the face material before all the other materials, so it's the only one that displays correctly:

Image of error

Also, here is the blend file as well (with all the textures packaged in), if anybody wants to investigate the issue directly: https://drive.google.com/file/d/1R_Yn7RfQlKksQDSbEfTezUdB4iAYeJkL/view

This is how the character is supposed to look normally: https://i.imgur.com/WypNgRa.png

Thanks in advance to anybody who's willing to help!

$\endgroup$
1
$\begingroup$

From what I can tell from looking from your file, the only affected area is the hair (now that I look again, maybe the eyes too), which seems to lack a UV map. I selected the section and did a crude "sphere projection" unwrap and was able to get a texture on it.

Unwrap1

Unwrap2

The problem is, that when I connect the texture that came with it, it's not clear how it's supposed to be oriented. I tried several different unwrap methods, as well as different placements in the UV space, but I couldn't get it to line up in anywhere close to a satisfying fashion. Maybe you will have better luck than I.

$\endgroup$
  • $\begingroup$ Thank you for taking the time to look at the file for me! I seemed to remember a few attempts where it was instead the scalp/hair texture that displayed correctly when I assigned it a texture first, but the face texture just showed up as solid black when I tried texturing it afterwards. I just tried again now, though, and it seems your observation is correct -- now the face texture always works but the other textures never work no matter the order I assign them in. Weird, maybe I changed something in the file without knowing it in between my attempts? (cont. in next comment) $\endgroup$ – Sighawke Aug 23 '20 at 3:08
  • $\begingroup$ In any case, I'm guessing you're right that it has something to do with the UV maps not importing correctly. I think I've tried redoing the UV maps from scratch before, but like you, unfortunately I haven't had any luck figuring out the projection lol. Not sure how I'll get the textures right...but in any case, thanks again for checking it out! $\endgroup$ – Sighawke Aug 23 '20 at 3:08
  • $\begingroup$ No problem. If it's worth anything, the best results I got were from unwrapping by selecting the area and just choosing plain "unwrap". When I moved it certain ways, you could see where the scalp is supposed to blend into the hair, but I don't know what to do with the "neck" area. There is a hole in the image if I move it around which I assume lines up with the empty "face area" but the correct orientation still eludes me. $\endgroup$ – Christopher Bennett Aug 23 '20 at 3:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.