1
$\begingroup$

I'm trying to make a beveled "B". I have a perfectly flat B that I'm extruding, but Blender keeps adding unnecessary lines. Scaling to Z 0, limited dissolve, etc will not remove them. Deleting them breaks the face.

These lines mess up the bevel process, even if I only select the 90 degree edges of the geometry. How do I force blender to just generate a flat, uninterrupted top surface?

enter image description here

$\endgroup$
2
  • 2
    $\begingroup$ Edges might seem unnecessary to you but they aren't unnecessary to geometry rendering process, even if in viewport. See devtalk.blender.org/t/faces-dissolving-problem/4419 and developer.blender.org/T68888. You can model that with curves instead / not convert from text and bevel that with their facility. Tldr though is "topology should be changed and don't overuse Ngons" $\endgroup$ – Mr Zak Aug 22 '20 at 14:57
  • $\begingroup$ Is there any way to automatically create a topology that can be easily beveled? I don't want to have to carefully reconstruct the top layer of every letter in a sentence $\endgroup$ – tape2020 Aug 22 '20 at 15:41
1
$\begingroup$

The simplest way to bevel is not to convert the text to mesh, but to use bevels within the curve's geometry.

enter image description here

Converting curves (or text, which is another kind of curve) to mesh will almost always result in terrible topology.

$\endgroup$
1
  • 1
    $\begingroup$ This eliminates some problems I was having, but now the letters are getting "fat" and crowding into each other. Is there any way to constrain this setting to Z-axis only? $\endgroup$ – tape2020 Aug 22 '20 at 17:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.