2
$\begingroup$

So I'm making a basic animation for a character dropping down consisting of a rigged mesh and a cloth simulation. When I play it, the character actually moves in the viewport, even in Render Preview. When I render it using Render Animation, however, the character seems not to move (apart from the cloth, apparently).

Here is the example render result in the output folder, but the camera is moved upwards a bit to see character's original position. Render result in my output folder As you can see, the character doesn't move. The cloth here actually moves with the simulation, though.

What I checked so far:

  • Making sure the "visible in render" on armature modifier is active in viewport,
  • Making sure that the step size is not 0.

Here's the blender file.

Edit: I realized that when I render an animation, the only thing that is rendered is the current frame that is on my viewport (aside of the physics). So if I my workspace is at frame 35, the character is stuck just like what it should be at frame 35. The clothes are still, oddly, fine, though.

$\endgroup$
5
  • $\begingroup$ I can't reproduce the error, the file renders just fine. $\endgroup$
    – susu
    Aug 20, 2020 at 4:50
  • $\begingroup$ @susu I redownloaded that .blend file, re-renders it and it still doesn't work properly. Does the output location or preference matters? Because this might be the only difference between devices. $\endgroup$
    – PseudoLW
    Aug 20, 2020 at 5:17
  • $\begingroup$ you have set a path for the output, but not a name for the file. $\endgroup$
    – susu
    Aug 20, 2020 at 5:36
  • $\begingroup$ I already set the path and it still doesn't work (it renders new image but the image is still empty). Moreover, Overwrite on, placeholders off, file extensions on, cache results off, PNG RGB, 8 color depth with 15% compression. $\endgroup$
    – PseudoLW
    Aug 20, 2020 at 6:02
  • $\begingroup$ I realized something so I added my new observation at the end of the question. $\endgroup$
    – PseudoLW
    Aug 20, 2020 at 6:07

1 Answer 1

1
$\begingroup$

I found the answer why does anyone else can't replicate my error and why does this error exists in the first place.

So I used an external plugin called "wiggle bones", and I realized that you're supposed to bake the animations first before rendering. Others might not have this plugin installed; that's why they don't have this error.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .