0
$\begingroup$

I had some issues with my project created in Blender 2.82a, which is not being correctly opened by newer versions.

I created a ticket (https://developer.blender.org/T78960) and there it was told be that "the problem is actually that your Cantos collection has an empty instancing that collection, this creates a very bad infinite loop." (https://developer.blender.org/T78960#989403).

However I don't know how to fix this error, so I always have to use 2.82a to open these projects.

Could anyone download the project (it's in the original ticket above) and show me what I have to do to fix it to be correctly opened by newer Blender versions?

$\endgroup$
2
$\begingroup$

The problem has to do with an empty that is in a collection attached to your Cantos object that cannot be opened to alter the contents (presumably because the empty is instancing it's own parent collection - there's your infinite loop). The solution, then, is to delete it, as I cannot see what function it serves other than causing problems (although you may have a different reason for needing it). However, the collection also contains a mesh that is the counterpart to the one on the other side. We'll deal with that in a minute.

First start by finding and deleting the offending collection:

Broke1

You will see that this removes the clamp, and also forces the collection to dump it's contents, which in this case is the offending empty. Isolate and delete this too.

Broke2

To put the clamp back (either in object mode, or edit mode - depending on what you want), I found duplicating and moving by -4.75 units on the X axis puts it right back in place. Here's a picture from the file open in 2.83.

Fixed2.8

I'll also post the blend in case you need it quick.

File is here -

$\endgroup$
7
  • $\begingroup$ Thanks, but I tried to do the same here and also I downloaded your file and it still not showing the layers (when trying to open it with the lastest 2.83.5): i.imgur.com/id9UFl8.png. Have you tried to open your file with 2.83.5? $\endgroup$ – Rogério Dec Aug 20 '20 at 0:58
  • $\begingroup$ No. I tested with base 2.83 LTS. I can't see why it should be that different in 2.83.5 though. I also downloaded the file I uploaded and opened it just to test, and everything's where it should be on my end. I guess the answer lies in something that got changed between 2.83.0 and 2.83.5. I can't see what else it could be though.... $\endgroup$ – Christopher Bennett Aug 20 '20 at 1:02
  • $\begingroup$ Here exactly when I open the project you sent me with 2.82a: i.imgur.com/3Mej4AP.png. And here when I do the same with 2.83.5 (and it's the same since 2.83.2): i.imgur.com/yEivlGL.png $\endgroup$ – Rogério Dec Aug 20 '20 at 1:13
  • $\begingroup$ I would just like to get rid of version 2.82a, but I can't, because these projects are only opened correctly in this version. At the same time, the Blender people don't give me a solution ... $\endgroup$ – Rogério Dec Aug 20 '20 at 1:19
  • $\begingroup$ Yeah, that's weird. I'll keep looking for what's causing this, but I'm a bit at a loss. I'm pretty sure that Cube.001 is a clue, though, because there's a Cube.001 under the Tampa (Cover?) object below it in the scene tree. As far as I know, blender doesn't allow 2 things to be named the same, so they have to be related (instanced perhaps?). Maybe more is being instanced by that empty that I originally thought. $\endgroup$ – Christopher Bennett Aug 20 '20 at 1:27
0
$\begingroup$

The Blender Support team found the solution: https://developer.blender.org/T79936#999546

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.