2
$\begingroup$

As the title says, how can I get Materials that contain textures to work and not be shadeless in BGE that is set to Multitexture mode? I cannot use GLSL.

I need to use materials so I can control the specularity of my objects. If I set the Blend mode for my textures to Mix the object becomes shadeless, if I set it to multiply the object becomes black.

Here are some pics to demonstrate my predicament...

Normal viewport: Normal viewport image

BGE running, texture set to mix: BGE Pic 1

BGE running, texture set to multiply: BGE Pic 2

BGE running, no material assigned (using UV image texture): BGE Pic 3

$\endgroup$
  • $\begingroup$ It seems you are in 'Shaded able $\endgroup$ – Mike Pan Dec 16 '14 at 0:13
2
$\begingroup$
  1. Unwrap the UV texture
  2. Add a material
  3. Check "Face Textures" under Options in the materials panel.

You may now adjust the spec. Make sure the textures panel is empty.

$\endgroup$
  • $\begingroup$ I could have searched my whole life before knowing the texture stack has to be empty....Thanks. Also is it possible to use normal maps in Multitexture mode ? $\endgroup$ – Yvain May 17 '16 at 8:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.