0
$\begingroup$

So I'm trying to make a smooth spherical cut in my object, I'm using the same object (icosphere) to cut both my meshes and it's worked fine on the right (hammer spike) and made new faces where it's cut, but its not making new faces on the left mesh (hammer head).

If it matters I had used a different object (UV sphere) earlier on the same object but removed that side made with that boolean and duplicated the front, mirrored it, and joined the vertices to make edges and faces. Then I separated the left and right meshes into new groups as you can see in the outliner.

I removed duplicate vertices and the face normals are correct, I've also tried a solidify modifier like some other related problems prescribe but it just made it more wacky.

how do I make the boolean tool make the new faces like it has before?enter image description here

enter image description here

$\endgroup$
0
$\begingroup$

The problems I have with booleans usually relate to two meshes having one or more vertices in the same place. You might be able to fix this by scaling one of the objects slightly, but this obviously will change its size. You might be able to manually move the offending vertices out of each others' way.

Another possibility is you created an object in an older version of Blender, and have now opened it in a newer version of Blender. The data structures are not the same, and booleans will give unexpected results.

Another thing you can try is to run the 3d printing checks, and fix any problems that crop up before applying your booleans.

$\endgroup$
1
  • $\begingroup$ If there are two meshes with overlapping verticies, it is better to select them both and then go into edit mode. After that just hit M>Merge by Distance. $\endgroup$ May 20 at 22:24
0
$\begingroup$

The best way I have found to resolve problems with booleans is to use the 3d print tools, which is included with blender.

Enable the 3d-print tools in the preferences, open the 3d printing toolbox, then click on "check all". The add on will flag all the problems it finds.

Non-manifold edges often indicate the mesh was not solid before you added the boolean.

Non-flat faces usually indicate there are more than 4 vertices to the face, and usually can be resolved by changing the faces to quads or trigons.

You may have to collapse the modifier stack partially or fully by applying previous modifiers before adding a boolean.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.