0
$\begingroup$

I was searching, and command line rendering is working, but not on GPU. I also find something with custom python script to force it to GPU, but it doesn't work either, probably because of Blender version. I have a really huge scene, which randomly gives Me "out of memory" error, but when I reset Blender it renders, sadly this will not work for Me, to re-run the rendering all the time.

I need help in launching Blender from command line with GPU rendering. Also it need to be OPTIX, because is a lot faster on RTX cards. I don't know python, can someone help Me run it for Blender 2.91? It need to be 2.91 from builder.blender.org, because it has crucial VDB bug repaired, and I'm using VDB sequence.

$\endgroup$
7
  • 2
    $\begingroup$ There is nothing you can do if "out of memory", which basically means that the scene does not fit into the memory of your graphics card. Make sure latest drivers installed, try to reduce the amount of objects in your scene or render using the CPU. Another option is to upgrade your hardware, meaning adding another graphics card... Also splitting up the render into multiple chunks does not help either since the complete scene needs to be transfered into the memory. $\endgroup$
    – brockmann
    Aug 16, 2020 at 16:02
  • 1
    $\begingroup$ You could try this script. If it works for you, I can write an answer that also enables OptiX. It won't help if you run out of memory though. $\endgroup$
    – Robert Gützkow
    Aug 16, 2020 at 16:58
  • $\begingroup$ Brockman_ as I mention if Blender is reset it works further, but after few frames it got memory error, then I need to reset again. I know that this is because of scene, but the scene is optimize maximally, nothing further can be changed. Robert Gutzkow- sadly this script use CUDA, and I really need OPTIX, as OPTIX is different, I assume this script will not work with optix. And I don't know Blender from python, scrupting side, I can't change it to have Optix enabled. $\endgroup$
    – adrian2608
    Aug 16, 2020 at 17:03
  • $\begingroup$ The out of memory error will not magically disappear when rendering from CLI though. The script is currently only using CUDA but can easily be extended. Before I do, please test if the current script works for your task. If it doesn't, then extending it to OptiX won't help either, it would only improve the rendering speed. $\endgroup$
    – Robert Gützkow
    Aug 16, 2020 at 17:10
  • $\begingroup$ Suggest add all relevant information to your question eg. what do you mean by reset exactly. Agree with Robert btw. recommend testing the script @adrian2608 $\endgroup$
    – brockmann
    Aug 16, 2020 at 17:58

0

You must log in to answer this question.

Browse other questions tagged .