0
$\begingroup$

I have been recently doing the blender donut tutorial and ran into a problem regarding the sprinkle particles. The particles (hair) keep appearing on the underside of the icing. As seen in the image below, most of the hair particles only come out from the bottom of the icing.

I tried to readjust the normals but I realised the normals were already correct. (Blue colour donut in image)

Someone suggested following through the weight painting part of the tutorial. However, the sprinkles still remain on the underside of the icing.

What is the actual problem and how do I solve this?

Particle settings below enter image description here

Edit: @moonboots Thanks the hair particle problem has been solved. How do I prevent the submersion of the sprinkle particles?

enter image description here

$\endgroup$
  • $\begingroup$ What is your particle setting ? Can u add an image of it? $\endgroup$ – Nxdhin2005 Aug 16 at 7:10
  • $\begingroup$ maybe share your file: blend-exchange.giantcowfilms.com $\endgroup$ – moonboots Aug 16 at 8:36
  • $\begingroup$ @Nxdhin2005 Image of settings added $\endgroup$ – FloppyFish Aug 17 at 10:48
  • $\begingroup$ @moonboots just shared the file $\endgroup$ – FloppyFish Aug 17 at 10:53
3
$\begingroup$

It has to do with the Solidify modifier, I guess if you leave the Solidify on top of the modifiers stack and don't activate the Emission > Source > Use Modifier Stack (which would make the object emit both on bottom and top, it's not what you want) it considers that one side must be the emitting one and not both, and it may not be the one you want. In that case maybe simply flip the normals in Edit mode and the particles will be displayed on the top, or put the Solidify modifier on the top of the modifiers stack

| improve this answer | |
$\endgroup$
  • $\begingroup$ Emission > Source > Use Modifier Stack and Solidify on top of the modifiers stack was already applied when the problem was still persisting. I tried flipping the normals as you suggested and it worked. It's just that all my sprinkle particles are half submerged into the icing instead of being on top of the icing. How should I go about this? $\endgroup$ – FloppyFish Aug 18 at 11:00
0
$\begingroup$

Use Dupli Objects in the Particle System Render settings as it looks like it's Path now. enter image description here

Also, just in case, flip normals.

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ My current settings is already in rendering as object and not path. I tried changing it to collections but the issue still persists $\endgroup$ – FloppyFish Aug 17 at 10:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.