1
$\begingroup$

I am following the concept of using the array modifier on an object, using an Empty axis, to create 12 points on a clock face.

I have failed to get to the point of turning the axis to create each new object copy.

The issue is that as soon as I select the Empty as the Object Offset, I get exponential creation of cube objects with huge dimensions.

I thought I had set everything correctly on my object.

The cube object dimensions are .002m x .040m y .001m z

This is .11615 up the Y axis.

The Empty is at the 0 origin point

The Array modifier on the cube has a Fixed Count of 12 with Relative Offsets ticked and set to 0

As soon as I tick the Object Offset with the Empty object, I get the huge object dimensions created (eg the X dimension is 1999999878979204987924730871808 m!!!!!)

I have attached images of the object, empty, and result of Object Offset.

Also, I have saved a version of my issue, without the Object Offset ticked, at https://www.dropbox.com/s/b961mhcttzhbzfq/stack.blend?dl=0

I realise I will be missing something simple but have not spotted this in videos I have seen online.

Cube objectEmpty objectResult of Object Offset

$\endgroup$
3
  • 3
    $\begingroup$ Almost always a scale issue. Make the cube object the dimensions you desire and apply scale Ctrl-A - Scale $\endgroup$ – batFINGER Aug 15 '20 at 19:50
  • 1
    $\begingroup$ Try Applying the Scale to the object before using the modifier. In Object mode select the object then using the keyboard shortcut Ctrl + A, open the Apply menu and choose the option All Transforms. $\endgroup$ – 3fingeredfrog Aug 15 '20 at 19:50
  • 1
    $\begingroup$ Yes as Batfinger says you need to apply the scale of your object. Also, if you want your object to rotate around the empty, put its origin at the same point $\endgroup$ – moonboots Aug 15 '20 at 19:50
1
$\begingroup$

You need to go to the cube and enter Ctrl + A and hit scale to apply the scale of the object, this is to avoid the size issue. However this does not completely solve the issue because when you rotate the empty by a whopping -800 degrees on the Z axis it is off centered and the rotation is not right as seen below.

enter image description here

To fix this, remove the empty as the object offset of the cube, and put the cursor with Shift + S in the center of the selected cube. Then create a new empty and make it a child of the empty at the center of the scene by clicking the new empty and Shift selecting the empty in the center then hitting Ctrl + P > Object.

enter image description here

Afterwards make the Object Offset in the array the new empty at the center of the object. Now you can rotate the center empty by 30.1 degrees (360 degrees / 12 pieces, the added 0.1 makes it more centered somehow). EDIT: 30.0939 is the precise rotation seems like.

The final result should look like this with no weird rotations.

enter image description here

$\endgroup$
2
  • 2
    $\begingroup$ Keeping it simple :) 1) With object selected Ctrl A > Apply Scale, Ctrl A > Apply Location. (or Apply All Transforms). 2) Array Modifier switch from Relative Offset to Object offset (Empty). 3) Turn Off Proportional editing in the Header of the 3D Editor. 4) Select empty rotate 30° in Z axis (R Z 30). Done. $\endgroup$ – 3fingeredfrog Aug 15 '20 at 21:53
  • $\begingroup$ Ohhh, proportional editing was most likely the problem. I was very confused because I had used this method so many times for castle towers and lighthouses and weird rotations were never an issue. Thanks for clearing that up, both methods work but yours is definitely a lot easier. $\endgroup$ – MrWaffleman Aug 16 '20 at 3:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.