2
$\begingroup$

I'm super new to blender and wanted to make some simple heart shaped object.

I've created this, but adding a solidify modifier makes a gap, which obviously I want to fill. I got no idea how to do this, due to my lack of experience.. Any ideas?

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here enter image description here

enter image description here enter image description here

$\endgroup$
7
  • 1
    $\begingroup$ @Nxdhin2005 Hi. We should be removing "thanks" and "any help appreciated" from posts, not adding them in. See: meta.stackexchange.com/questions/2950/… $\endgroup$ Commented Aug 15, 2020 at 9:02
  • 1
    $\begingroup$ @Kuksu i guess you have that kind of solidifying because the left and right half of the mesh are un-joined( you might have used a mirror modifier). $\endgroup$
    – Nxdhin
    Commented Aug 15, 2020 at 11:57
  • $\begingroup$ @Nxdhin2005 not in this case. These are my steps: 1. built a heart shape from one cube and two cylinders as separate objects 2. joined them 3. removed front, back and inner unwanted faces (leaving only heart shaped flat sides) 4. added thickness with solidify modifier (as suggested here: blender.stackexchange.com/questions/108512/… ) $\endgroup$
    – kuksu
    Commented Aug 15, 2020 at 13:45
  • $\begingroup$ So you r saying that you made it with 3 different objects. Can u post an image of the entire mesh in edit mode? I think you have a screwed up topology $\endgroup$
    – Nxdhin
    Commented Aug 15, 2020 at 13:51
  • $\begingroup$ @Nxdhin2005 edited $\endgroup$
    – kuksu
    Commented Aug 15, 2020 at 14:11

3 Answers 3

3
$\begingroup$

Bevelled curve alternative

This is not answering how to close the solidify gap, more offering an alternative to makng the object.

Add a default bezier circle and enter edit mode. By default all points are selected. Set the handle types (particularly of top and bottom) to free

Control Points > Set Handle Type > Free

enter image description here Minimal effort example

Next add a plane, in edit mode delete its only face, exit edit mode and

Object > Convert > Mesh to Curve

it is now a "square curve" and can be made the bevel object of the heart. Scale plane to desired size.

enter image description here

$\endgroup$
3
$\begingroup$

Just as I said in the comments, it's happening because you you used two separate mesh (two cylinders) which's vertices were so close that you wont notice that there are two vertices. Solidify modifier does something similar to extruding and scaling inwards.

Its just an easy process. I will walk you through it-

First of all apply the object's scale with CTRL+A > scale (or else it will create uneven solidification).

Then go to Edit Mode and box select the vertices as shown and merge them with Alt+M > Merge at center. (Just M in Blender 2.83 and above)

enter image description here

Notice how the gap gets filled...

$\endgroup$
1
  • $\begingroup$ @kuksu does this answer your question? $\endgroup$
    – Nxdhin
    Commented Aug 16, 2020 at 12:04
2
$\begingroup$

The problem is that even though you joined the three objects together, there are still two/three distinct meshes within the object with duplicated vertices in the center. You can check this by selecting a vertex then pressing Ctrl+L (Select Linked).

enter image description here enter image description here

You can fix the issue by selecting the adjacent vertices and Merging them by pressing M > At Center. Note that I'm using the select box in wireframe mode with X-Ray enabled, this is so that the selection will catch any vertices that are hidden behind other geometry.

enter image description here

If you don't like the uneven result, change the solidify modifier mode from Simple to Complex

enter image description here

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .