0
$\begingroup$

I was adding a condensation normal Map to the cup near the rim. I was doing this in material preview which made nothing look wrong. Then when I did a test render it didn't look correct. Like the bottom half of the liquid was cut off and that for some reason the condensation texture was there.

It's like the bottom portion of the liquid material I had inside somehow got removed during the UV editing. I've looked at the UV tab, shading tab, and all through my materials tab and I can't find what caused the problem. Nothing looks wrong in the material preview mode which is even more confusing. I haven't been able to find anyone with similar problems.

Here is the .blend file for anyone who wants to go hands on.

I am relatively new to Blender so don't be surprised if it is something fairly obvious.

$\endgroup$
  • $\begingroup$ Hi there:). Can u share your .blend file to get quick response? $\endgroup$ – Nxdhin2005 Aug 14 at 7:15
  • $\begingroup$ @Nxdhin2005 Here is the .blend file for you to experiment with blend-exchange.giantcowfilms.com/b/MO8llK0r sorry for the delay with replying as it is very late here. $\endgroup$ – QuakeR Aug 14 at 8:14
1
$\begingroup$

The lower faces of the liquid are interfering with the lower faces of the inside of the cup. You can fix this by scaling the liquid in the Z axis so that these lower faces are a little above the lower inner faces of the cup. To do this:

  1. Select the Liquid object and in Edit mode with Face select mode active, select the face in the middle of the top face of the Liquid.

  2. With the keyboard shortcut Shft + S choose the Cursor to Selected option.

  3. In the Header change the Pivot Point to 3D Cursor (see screenshot below).

enter image description here

  1. Still in Edit mode select All of the Liquid object.
  2. Now scale a little along the Z axis so that the bottom of the liquid is not touching the bottom of the cup.

Tab out of edit mode and try a render :

enter image description here

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.