0
$\begingroup$

So I'm using a Principled BSDF shader with transmission to 1 in Eevee. I've enabled screen space refraction in the shader and enabled screen space reflections and refractions in the render tab. I've covered so many solutions on stackexchange yet I'm still getting this gray in the glass.

I thought it was reflecting the background. I have changed the background to white (also tried blue) but it make no difference. I've played with the refraction depth and IOR, but nothing helps.

What is going on here?

enter image description here

enter image description here

$\endgroup$
3
  • 1
    $\begingroup$ could you please share your file, or a part of it? blend-exchange.giantcowfilms.com $\endgroup$ – moonboots Aug 13 '20 at 17:12
  • $\begingroup$ Cheers, just uploaded it. $\endgroup$ – sebjwallace Aug 13 '20 at 17:19
  • $\begingroup$ it looks like glass is still not optimum un Eevee, as Christopher says you probably need to find a way around with Glossy, Transparent, Refraction nodes etc... $\endgroup$ – moonboots Aug 13 '20 at 17:51
1
$\begingroup$

I find this setup best to mimic proper glass in eevee. Pay attention to the Blend Modes I have highlighted (I didn't use a transparent shadow but you can if you want). You can leave the IOR at default, but I find 1.05 gives a better look for a lot of things.

GlassEEVEE

$\endgroup$
7
  • $\begingroup$ Thanks for your setup mate. I still get the grey in the non-geometry areas though. Although it does look quite nice regardless. Will try it again if I get this issue sorted. $\endgroup$ – sebjwallace Aug 13 '20 at 17:26
  • $\begingroup$ Yeah, I see that not. You can remove some of it by removing the refraction component, but that leaves the glass "frostier" than it should look. $\endgroup$ – Christopher Bennett Aug 13 '20 at 17:38
  • $\begingroup$ For some reason, your world background was interfering, until I noticed the "use nodes" checkbox was unchecked and then I checked it. That let the world light come through, which was way too bright. I just disconnected the background altogether, and things cleared right up Try for yourself - you may want to tweak settings afterwards to get the correct world lighting back $\endgroup$ – Christopher Bennett Aug 13 '20 at 17:54
  • $\begingroup$ I've disconnected the nodes and still getting this i.stack.imgur.com/CJUmE.png I also reset the background all together. Did you get it working correctly? $\endgroup$ – sebjwallace Aug 13 '20 at 18:02
  • $\begingroup$ You mean the sphere? I'm not sure what's going on there. As far as I can tell, there's something in your world setting causing this, but I can't put mu finger on it. $\endgroup$ – Christopher Bennett Aug 13 '20 at 18:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.