3
$\begingroup$

Hello!

I'm kinda new to Blender so I apologize if the answer to my problem is obvious but I cannot figure out how to solve it by searching it on the internet. So, I made a curvy surface that is made of many faces.

enter image description here

I extruded it, applied Rotation & Scale, Recalculated Normals Outside, and then tried to Bevel the corner edges.

enter image description here

The Bevel effect came out pretty uneven because of the vertices getting in its way. I tried dissolving the top edges and making a surface again by pressing F and then I tried to dissolve some of the top vertices as well. The the beveling was actually even, but I was losing my curvy geometry as a result and messing up the faces a lot.

enter image description here enter image description here

Do you know if I can get rid of the vertices without losing the curvy geometry or get the Bevel tool to work without stopping at the vertices it finds along the way, like skipping them or beveling precisely using a different method? (besides Bevel Node and the Bevel Modifier)

I would appreciate very much every sort of help anyone can provide me with, because I'm struggling with this issue and always let it slide but it's bothering me a lot as I always use the Bevel tool in order to make smoother corners and edges.

Thank you very much in advance!

$\endgroup$
  • 2
    $\begingroup$ Couldn't you add a loop cut around the top and bottom of the object to kind of "square out" the corners? $\endgroup$ – Christopher Bennett Aug 12 at 22:28
  • $\begingroup$ as CtrlAltF2 says you have a lot of edge loops, you could bend your plane with much less if you use a Subdivision Surface modifier, and therefore easily create your bevel, unless you have any reason not to use Subsurf. What Christopher proposes is another solution $\endgroup$ – moonboots Aug 13 at 8:54
  • $\begingroup$ @moonboots The thing is that I duplicated this surface from another object and I want the curve to fit perfectly the curve of the primary object. I will actually try use the Subdivision Surface modifier as the last resort along with what CtrlAltF2 proposed. Thank you! $\endgroup$ – Vicky Aug 14 at 18:09
2
$\begingroup$

Assuming you want to bevel at a 45° angle:

First (with the Ctrl + B hotkey) you need to press C to enable clamp overlay which will make the bevel stop when a bound has been reached. enter image description here Then you want to select the mesh and merge by distance (F3 and search it) because the 2 edges will be slid up against each other so that the vertices are very close.

Afterwards you can select the 2 edges forming the bevel and have as many segments as needed. enter image description here If you want to make the bevel even bigger, then you can repeat this process again (minus making all the segments) by bevelling the 2 outer edges with 1 segment and with Clamp Overlay turned on. Every time the outer edge meets with another edge, use merge by distance to prevent 2 edges in one place.

You should also join vertices to make sure you don't have an Ngon like so enter image description here You can do it like this but the cleaner and more efficient option is just to use less edge loops like what CtrlAltF2 mentioned earlier.

Edit: Additional picture showing the maximum bevels I could do, not pretty though. enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ This method actually helped me making the bevel slightly bigger by passing by the first edge like in your image. I tried to make it even bigger by doing the same thing only in the outer edges but the curve of the beveling stays the same, it's just extending by adding more segments past the outer edges. The point is that the curve doesn't expand while moving past the outer edges. You can change only whatever you did after defining the first beveling curve. Nonetheless, it helped expand it a bit so thank you a lot! $\endgroup$ – Vicky Aug 14 at 17:44
  • $\begingroup$ Did you make sure to merge all vertices? Because the same thing happened to me, after the first bevel it wasn't changing. Only after merging vertices was I able to bevel more and more. Just make sure to keep it at 1 segment until you're satisfied with the size of the bevel. $\endgroup$ – MrWaffleman Aug 14 at 18:24
  • $\begingroup$ I just put the picture of the maximum bevels I did, if that doesn't look right to you. The best way to get the kind of bevel you want would just be to make a rotated cylinder and fit it to your mesh. Because it seems like you want a very steep angle/bevel. $\endgroup$ – MrWaffleman Aug 14 at 18:29
1
$\begingroup$

The problem with your mesh is that you have too many vertices.

So, to make this shape, I would start with a cube and scale it to about the size I want (in edit mode so as to preserve a uniform scale). Then I'd add a couple edge loops through the middle of the mesh to draw out the curve. This would look extremely blocky, so I'd add a subsurf modifier. To make the edges of the mesh nice and sharp, I'd crease it (Keep sharp edges when using subdivision surface). Then it would be extremely easy to bevel as needed.

| improve this answer | |
$\endgroup$
  • $\begingroup$ The thing is that I duplicate this surface from another object and that's why it has a lot of vertices on it because my primary object has them as well and I want the curve to fit perfectly the curve of the primary object. I already had this method as the last resort but thank you! $\endgroup$ – Vicky Aug 14 at 18:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.