0
$\begingroup$

I have seen some similar questions, but I don't think my problem is that I have overlapping faces. I have also tried adjusting the lighting level but the problem persists. When cycles render preview does 1 or 2 out of the 32 render cycles then the coffee looks more or less correct but the end result is always grey and white and washed out. I might be able to fix this with an overlay of color in the nodes, but is there any way to avoid the problem in the first place? preview render with 1 or 2 cycles rendered

render preview

blend file https://drive.google.com/file/d/17M1Bm2xdQxLtuhR7DOEmqay4WGezRiSE/view?usp=sharing

UPDATE: I turned the light intensity down and changed to darker base colors for world and sun light sources. I changed the base color of glass and coffee which improved the glass slightly, but the coffee is still ridiculously reflective. I have roughness at .5 and turning it up to 1 does not help.

new render

Final result after applying instructions in checked answer

modified liquid only

and after adding a transparent BSDF and decreasing transmission and increasing roughness of glass

modified liquid and glass

I also decreased the light intensity for world and both lights to .4 for world and about 100 watts for each light down from 600

Final version -- https://drive.google.com/file/d/1z5UkbsWIKdtGmvthzcef6k3zenHixaNm/view?usp=sharing

$\endgroup$
3
  • 1
    $\begingroup$ your base color is white, your Transmission is at 1, the World color is almost white and your light strength is at 10, so it give a rather clear grey color $\endgroup$ – moonboots Aug 12 '20 at 17:52
  • 3
    $\begingroup$ Please don't make users go through many links to understand the question. Use the tools from this site to post images, so that they show as part of the post. How to add images to a question $\endgroup$ – susu Aug 12 '20 at 18:05
  • $\begingroup$ I have updated to include the images. I changed colors and light strengths. this helped the glass look better but the coffee is still ridiculously reflective I updated the google drive blend file to match the new settings $\endgroup$ – ubikempanada Aug 12 '20 at 20:45
0
$\begingroup$

Your environment lighting (world and light) was very bright. So first thing, change your lighting. Also, your coffee material has a Transmission of 1, which makes it reflect the environment like a glass, and a Roughness of 0.55, which makes the reflection scattered all over the surface, it's not what you expect from water, and it creates a rather grey material, you can't see the Volume Absorption effect any more.

enter image description here

If you don't want this scattering effect, which would make more sense, low down the Roughness value:

enter image description here

You can also mix your BSDF with a Transparent node to lown down the glass effect:

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.