0
$\begingroup$

I haven't been able to find anything on this.

Whenever I try to render anything with cycles as the render engine, it immediately shuts down and reboots my computer, meaning it shuts down, posts, boots, etc, not a soft reset. This happens whenever I render an image, or if I have the engine set to cycles and I have the viewport set to render.

I've looked through over 50 different forum posts on this site alone, and many more on google, and found no answers. I will however provide a debug log from the last time this happened. this happens no matter what .blend file I open, even just the default cube causes this. (the log I provided is with the default cube)

$\endgroup$
  • $\begingroup$ sorry i forgot to add the files on the post, here are google drive links to the files. drive.google.com/file/d/1m08h2pfqOt3z6Me5dQyIuE1kFh1b886B/… drive.google.com/file/d/1pwQsoUCh0ydRChNLc0ya0gLY7rIl_qNG/… $\endgroup$ – anto 77 Aug 12 at 2:48
  • $\begingroup$ Best case scenario, you have to update your drivers or reinstall blender. Worst case scenario is a possible problem with your hardware. $\endgroup$ – Nascent Space Aug 12 at 3:08
  • $\begingroup$ It could be that either your CPU/GPU is overheating, or you have an unstable CPU overclock? Cycles is very demanding, maybe monitor your temps immediately after you switch to cycles to see if this could be an issue. $\endgroup$ – Cultmethod Aug 12 at 3:19
  • $\begingroup$ no, it's definitely not that. I'm currently not overclocking the CPU nor GPU, I have a 1080TI founders edition with high performance non-conductive thermal paste on it, same on the CPU, a 3900x, with a functioning liquid cooler. I also have an overkill power supply for the headroom for future upgrades. I work as a technician at a local repair shop, so I can firmly say that its software, I just don't know which aspect of blender is causing the crash, or if its a driver issue. $\endgroup$ – anto 77 Aug 12 at 3:25
  • $\begingroup$ ok, so I also figured id post more info to help solve this. I've tried with older Nvidia drivers along with the newest one. I have also tried with another kit of memory, running it using only CPU, only GPU, and both. $\endgroup$ – anto 77 Aug 12 at 3:36
2
$\begingroup$

TL;DR: it was a bios setting that by default, shut down the computer when you tried to use it

full version:
I did end up finding the issue, but its what I least expected. to, in the bios on my mobo, you can control the current going through the VRM's, you can adjust it in percentage so that if it goes over a certain percentage, it'll enter a shutdown state and reset. mine was set to 35%, of the total allowed current draw, so it would shut down if it went over that. I was measuring different points on the motherboard, and I noticed that the shutdown on the VRM controller was being triggered, but there was no voltage drop, (which would mean its a power supply) so I went into bios and I found probably the most annoying default bios setting I've ever dealt with, the current shutdown limit, mentioned above.

my full setup, for anyone else having this issue: ASUS TUF gaming+wifi x570 running the second latest bios as of 8/12/20 (all stock settings aside from the boot order) 3900x, stock clocks with a 240mm AIO 1080ti founders edition, stock clocks 32 GB 3200MHz DDR4 corsair vengeance Seasonic 900 watt PSU 3 HDD's, an ODD, and an M.2

running windows 10 home edition x64 fully updated as of 8/6/20 Blender version 2.83 latest Nvidia drivers as of 8/11/20

steps to create the issue: render anything using the cycles render engine using the CPU.

steps to solve the issue: adjust bios settings, specifically under advanced<DIGI+ VRM<current shutdown, from 35% to 100%. another thing that may have worked is flashing on the latest bios, or re-setting everything to defaults, but I don't recall changing this setting, so it may be a bug in this bios rev, IDK, but this fixed my issues. hope it helps :)

P.S. sorry for the information overload, but I figure if anyone else has this problem, too much info is better than not enough info.

| improve this answer | |
$\endgroup$
0
$\begingroup$

Are you sure the power supply is fine? I had a beefy Corsair 650W PSU (not one of their low-end CX ones, either) on a system that drew maybe 350W, tops. Great build quality, nice quiet fan, stable for days.

Except when I played Deus Ex: Human Revolutions, and entered the elevator for the first time during the intro. About 10 seconds into the elevator ride, my PC would reset and plop me back at the BIOS to POST. It was consistent. Always that one spot--but only if I hadn't played the game in several hours. If I fired up the game again immediately after the reset, I could always get past that one spot.

The problem went away with a new, similarly-sized power supply. I have still never seen anything else like it.

Since you work at a computer shop, can you borrow another power supply to test?

Bear in mind, Blender may be using code paths (SSE, or AVX if your system supports it) that cause much higher power draw than other tasks that are behaving fine, like gaming.

You also might consider a synthetic stress test utility like Prime 95 ( https://www.mersenne.org/download/ ), which will invoke some very power-hungry sections of your CPU. However, I had run Prime95 on the system mentioned above with no issues, so you'll need to either stress it further with a 3D app (to get the card out of 2D/low power state) or just do the easy thing and swap out the PSU.

| improve this answer | |
$\endgroup$
  • $\begingroup$ actually I did end up finding the issue, but its what I least expected. to, in the bios on my mobo, you can control the current going through the VRM's, you can adjust it in percentage so that if it goes over a certain percentage, it'll enter a shutdown state and reset. mine was set to 35%, despite being the second newest bios revision that I flashed on there, without modifying it. I noticed it was odd that there was no voltage drop at the eps 12v header, but it entered a protective shutdown. I changed it to 100% and it works great now, ill be marking this solved now. thx for the help $\endgroup$ – anto 77 Aug 12 at 8:17
  • $\begingroup$ Glad you were able to solve it! Don't forget to mark your own answer as the correct one so people know what the issue is. It might help someone in the future! $\endgroup$ – supertanker13 Aug 12 at 15:01
  • $\begingroup$ that's what I'm hoping, this really stumped me for a while there, and I even had to break out a multimeter, not everyone will do that, and even then it was sheer luck I solved this. $\endgroup$ – anto 77 Aug 12 at 18:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.