5
$\begingroup$

When rendering this scene in Blender Internal, the wine glass in the scene has a dark shadow collect at the very bottom.

I have shadow transparency on, the shadow from the light turned off with environment lighting on and ambient occlusion on.
The shadow is only there when ambient occlusion is on and it is against the table. Is there a way to make this go away while keeping ambient occlusion on?

enter image description here

This is an image that has all of the details for the environment and for the glass material

enter image description here

$\endgroup$
  • 1
    $\begingroup$ Post the link.. someone will add the image for you. You can also post the blend file if you think it might help. $\endgroup$ – iKlsR Jul 19 '13 at 22:59
  • $\begingroup$ For your information, I have added to my original answer. $\endgroup$ – SteveW Jul 20 '13 at 11:23
  • $\begingroup$ You say it goes dark when the glass is against the table - is it right against it or leaving a small gap? Is the centre of the glass base raised slightly leaving a gap? Another thing to check is the simplify option in the scene settings, if turned on they can reduce the samples used and AO quality. $\endgroup$ – sambler Jul 20 '13 at 12:16
  • 2
    $\begingroup$ don't include Subsurface Scattering in a glass material, but do add more lights! Light needs to bounce around in the glass to come out again, that's why you need a higher 'depth' setting, go as high as you need. (use border render while testing) $\endgroup$ – zeffii Jul 20 '13 at 12:21
3
$\begingroup$

There are several thing that could cause this, including

  • Shadows

    Make sure that the table material has Receive Transparent enabled:

    enter image description here

    With Receive Transparent and Without Receive Transparent:

    enter image description here enter image description here

    As you can see form this render with the glass raised, the reason for this is that even if the glass casts a transparent shadow, unless Receive Transparent is enabled for the table, solid black shadow is rendered which the glass then refracts:
    enter image description here

  • Ambient Occlusion:
    Ambient Occlusion would cause this too, as it works by darkening surfaces that are close to other objects. (The closer the darker)
    Then you have the same problem as Receive Transparent, with the glass refracting the dark areas.

    Add blend mode:

    enter image description here

    Multiply blend mode, with the glass on the table and with it in the air:

    enter image description here enter image description here

    To make this disappear, you can enable Indirect Lighting in Properties > World
    enter image description hereenter image description here
    However, this can get your rendertimes rather insane, (Just for this low resolution render it took 2:27.26)

And as already mentioned by SteveW:

  • Depth
    The Depth setting from one to four:
    enter image description here enter image description here enter image description here enter image description here And at a value of 20 : enter image description here

Cycles

Probably the best way to do this is use Cycles, as you need caustics to get light to properly illuminate after being refracted through the glass.

(quick example:) enter image description here

$\endgroup$
  • $\begingroup$ Thank you, adding the indirect lighting worked, injunction with the settings that SteveW suggested, the shadow was reduced with 1-2 sampling passes. With the settings that I originally had, it took five passes to achieve the same result $\endgroup$ – Josh Jul 20 '13 at 22:21
  • $\begingroup$ Cycles might be good - but it's a shame about the graininess! $\endgroup$ – SteveW Jul 20 '13 at 23:13
  • $\begingroup$ @SteveW Quite.. (though this was only 100 samples, with less light then really ought be :P) And there is always Lux and YafaRay as well. $\endgroup$ – gandalf3 Jul 20 '13 at 23:29
2
$\begingroup$

If you are using Raytrace Transparency then this problem could be due to the Depth setting:

enter image description here

The default Depth of 2 is often not enough to give you all of the possible light inter-refractions, resulting in empty 'holes'.

Failing that, try this: In the Transparency panel set 'Alpha' to 0.1, 'Fresnel' to 2.0 and 'Blend' to 1.5 (You might need to juggle with these a bit). With Alpha set to 0.0 (as in your settings) the shadow areas are very dark and dense, and Fresnel has no value to work on. Also, for this 'glass' material I don't think you need Mirror, Subsurface Scattering or Receive Transparent to be on.

$\endgroup$
  • $\begingroup$ I have the depth up to 8 on both transparency and reflection, does it need to be higher than that? $\endgroup$ – Josh Jul 20 '13 at 5:31
  • $\begingroup$ @Josh OK, so this answer probably doesn't apply. Maybe you could add those details to your question. $\endgroup$ – SteveW Jul 20 '13 at 5:35
  • $\begingroup$ I added all of the details of the material to the question. Apologies for any inconvenience I may have caused. $\endgroup$ – Josh Jul 20 '13 at 5:55
  • $\begingroup$ @Josh No problem, I've added your pictures to your question. $\endgroup$ – SteveW Jul 20 '13 at 6:51
  • $\begingroup$ @SteveW I think Mirror is necessary if you want any reflections like most glass does in real life, though it will probably look glassy enough without them. $\endgroup$ – gandalf3 Jul 20 '13 at 22:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.