My middle mouse and shift button work on everything else, I even set it back to default factory settings, but it still doesn't work. I tried googling but nothing helped. I've also tried the alternative to the middle mouse, but it still doesn't work. I think the pan view is not working.

  • $\begingroup$ Does this happen even if you revert to factory settings? or on a specific file? $\endgroup$ Aug 10, 2020 at 13:20
  • $\begingroup$ Yeah it still happens after I default back to factory settings $\endgroup$ Aug 10, 2020 at 14:27
  • $\begingroup$ I think there is a problem in the pan view when opening directly a file and not first Blender and from there the file. This is the only way I found to move through the 3d view. Otherwize the Shift key is not working. Does anyone face the same? $\endgroup$
    – AntNova
    Dec 15, 2022 at 5:47

1 Answer 1


A comment might be too difficult to explain a test, so i post it as answer

What if you change your pan view to other shortcut, or manually add a new short cut to it?

It should be found in 3D View > 3D View (Global) > Pan View

enter image description here

Add a new shortcut: enter image description here

  • $\begingroup$ BTW I always change it to "shift + RMB" to pan view since "MMB" are too hard to press down in most of the mouse. $\endgroup$
    – HikariTW
    Aug 11, 2020 at 8:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .