0
$\begingroup$

For some reason some objects in my scene have these weird reflections, but others don't. All objects in my scene have the same material, but some behave differently. If i make the specular value 0 the reflection goes away, but then it looks different than the other materials, and I want them to all behave the same. Please help!

Attached is a link to a video of me showing you the problem. You can see the weird effect on the door, and on the wall.

https://drive.google.com/drive/folders/1inH5VpxNH4FzB5Dj2GUt-8H5olSETlda?usp=sharing

FYI (to the moderators) I tried using blender exchange but the upload never worked.

$\endgroup$
2
$\begingroup$

Just posting this so I can post the pic. I suspect the problem is that you have your light radius set too large. It's hard to tell from the video, but it looks like you have a point light above your "room". As you can see from the image below, a large light bleeds through the walls and reflects off the roof similarly to how it does in your video. If you have a point light with a radius that is large, consider reducing the size. If you don't want it coming through the walls, also consider enabling contact shadows, but bear in mind, this may require your walls to have some thickness to work properly. See below:

LightBleed

| improve this answer | |
$\endgroup$
  • $\begingroup$ I have no point light above my room. I'm mostly only using the world light shining through the windows to light my scene, and these material issues were a problem before I added any other lights such as the ceiling lights. This room was a downloaded room, so maybe there is a typical problem that comes with setting up someone else's scene? $\endgroup$ – Nick Abbott Aug 5 at 18:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.