1
$\begingroup$

I'm new to Blender and newer to the community. Please be kind with my ignorance.

I've created a landscape mesh with the True Terrain addon, looks really nice, but when I place the automatic textures of the addon it put them on the other side of the mesh. I've tried not using the texture given and add one with the shader editor, same issue. Also the normals of the mesh are facing the right direction. I've tried flippin them just in case, and same problem. Another thing to happen is when i render on cycles the mesh it's all streched and looks like a mess, works nice with the displacement off, but the texture still inverted. Experimental render and displacement and bump options are both checked.

I've tested this with Blender 2.83 and 2.9

With displacement With displacement

Without displacement Without displacement

Without displacement2 Without displacement

enter image description here

Node1

$\endgroup$
2
  • $\begingroup$ Can you show us (the relevant part of) your node tree? $\endgroup$ – Robin Betts Aug 4 '20 at 20:27
  • $\begingroup$ I added the nodes. I was able to sort of solve the problem though. In the material setting under surface i change it from "displacement and bump" for "bump only" and seems to keep the normals too. $\endgroup$ – Feders87 Aug 6 '20 at 23:38
0
$\begingroup$

Maybe try something like 2000m x 2000m x 500m (x, y, z) landscape dimensions but keep the sizes to 1 if you haven't already and see if that helps.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.