0
$\begingroup$

Well it might be a bug, it might be an odd function of Blender too. I am not really sure. The weird view only appears when in 'free view' in perspective mode. (The view where you gan orbit around your scene with the middle mouse button) The problem does not appear in orthografic view, in camera view, in rendered; shading and wireframe view and in the views from top, the side, bottom etc. (Also orthografic) Second weird thing is, I cant select any of the objects with a single mouse click. I now have to use the circle selector or draw the selection box. The grid in the viewport disappeared too.

I do not know if I clicked something wrom or used a 'bad' keyboard shortcut or if it really is a bug. I just want to get this dumb piece of garbage out of my viewport.

This picture shows the bugged view. Just as I said. In all the other view modes and in the camera etc. it is just fine.

issue preview

Download .blend file

$\endgroup$
0
$\begingroup$

The reason why your viewport goes haywire is because of the viewport's Clip Start/End values which you set to crazy amounts.
To give you an idea, your largest object is 2 000 meters (2 kilometers) wide, yet your viewport is set to render stuff up to 100 000 meters (100 kilometers) away.
And you also stuff close up to 1 nanometer from your viewpoint, that's 0,001 millimeters!
A sheet of paper is about 100,000 nanometers thick, a strand of human DNA is 2.5 nanometers in diameter. You really don't need those clipping values.

In most cases you shouldn't set the Clip Start below 0.001 (1 millimeter). Even that value is rarely needed, and it's only when you need to be really close to something, like when you modelize something of a few millimeters. On a large scene like that, you probably do not even need to set it under its default value: 0.1 m (10 centimeters)

As for the End Clip, it is way too large and will lead to rendering & performances issues. Unless you need to set your camera on one end of your map and be able to see everything up to the opposite end, you don't need more than 1000 m (1 kilometer).

Just a before/after comparison:

crazy clipping values

crazy clipping values

normal clipping values

normal clipping values

$\endgroup$
9
  • $\begingroup$ Alt + Z toggles the X-Ray mode but now the materials are ghosty. I think that one should be the x-ray because everything is half-opaque. But if I press Alt + Z again, everything just gets grey like before and I only can see the outlines... I really dont know what the heck caused this mess... $\endgroup$ – OrangeHead Aug 4 '20 at 11:22
  • $\begingroup$ Then in solid mode, check your shading options (the arrow icon at the right of voew modes icons), maybe there's something weird here. $\endgroup$ – L0Lock Aug 4 '20 at 11:30
  • $\begingroup$ Well I have no idea what could be wrong there. I tried unticking everything by its own and it did not change anything... $\endgroup$ – OrangeHead Aug 4 '20 at 12:19
  • $\begingroup$ Oh well... Apparently the shading view is also a bit bugyy, since all the meshes are half x-rayed too. I am pretty sure that is not what it is supposed to look. $\endgroup$ – OrangeHead Aug 4 '20 at 21:59
  • $\begingroup$ It's not just a matter of checkboxes, besides it's not really a good idea to toggle everything without knowing how things work. Please show a screenshot of your shading settings. Or share your original .blend file so we can dig in $\endgroup$ – L0Lock Aug 5 '20 at 9:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.