3
$\begingroup$

I think I accidentally turned on a setting but I don't know how or which one.

The mesh of my object disappears in edit mode and it is not hidden.

In solid mode, my object looks like this:

Solid view mode of object

But when I go to wireframe mode it only shows an outline of the object where I should see the mesh like this:

Wireframe mode without mesh

In my other projects, I can see the wireframe of the objects under edit mode like this.

Mesh of an object

As a result, I cannot select individual vertices, faces, and edges when I am in edit mode of that object.

These problems started occurring after I used the keyboard short cuts shift + D and P to duplicate and separate the object.

Thank you!

$\endgroup$
6
  • $\begingroup$ The "other problem" should be a distinct question. But to answer quickly, you can't access vertices, faces, or edges while in Object mode - that's by design. Just switch to Edit mode (Tab key). $\endgroup$
    – thibsert
    Aug 3, 2020 at 21:32
  • $\begingroup$ Hi, I apologize as I meant to put edit mode. I updated the question. Thank you! $\endgroup$
    – Mana
    Aug 4, 2020 at 15:17
  • $\begingroup$ Hello :). To prevent guessing, consider sharing your .blend. In case it's some hidden setting or a bug. $\endgroup$ Aug 5, 2020 at 14:16
  • $\begingroup$ Try disabeling "Hidden wires" in "Overlays"... That was my solution $\endgroup$
    – Bjorn S
    Feb 17, 2022 at 8:18
  • $\begingroup$ Sometimes old version files have unpredicted appearance. Append em in new scene. $\endgroup$
    – Yan S
    Jan 26, 2023 at 19:35

7 Answers 7

6
$\begingroup$

Let's try the most simple stuff, see if you haven't accidentally hide all, so in edit mode press Alt+H.

Other simple stuff is to press A and then press G and move around (if the mesh is in any case behind other object), you then must see a lot of orange points going around.

If that does not resolve the problem, in object mode set the Origin to the Geometry and in edit mode press Shift+S and (cursor to selection) and in view 3D cursor you can see the co-ordinates where the cursor goes, try to locate that and you must see the mesh, (don't press selection to cursor cause all your mesh will be compressed in one point)

If that does not solve, try to look in Object properties> viewport display > display as > and set to Textured or Solid. Under Show, check the In Front checkbox.

If you can't see still, see if you are in preview or render mode so it could be a transparent texture issue so you must adjust your UV maps.

Feel free to give me a feedback if case that none of them not solve the problem.

$\endgroup$
3
  • $\begingroup$ it appears that it has a lot of possible answers. Such questions are not encouraged in this community. Nice and detailed answer though $\endgroup$
    – Nxdhin
    Aug 29, 2020 at 7:21
  • $\begingroup$ @Nxdhin2005 I take my time registering to this page just to answer a person who seems to have problems in a software that i have been using for almost 3 years literally all day every day, since the type of question, you cannot know what is the exactly problem he is having, just to think that you can give an exact answer in a question like this is a complete no sence. $\endgroup$ Aug 31, 2020 at 10:11
  • $\begingroup$ Yes, @Royal Investment it's not your problem at all. I apologise if you felt my comment in another sense. The question is very unclear. It was the question's problem I guess. We encourage such detailed answers but the thing is if the specific problems are provided within the question you can simply answer to the point. It might even have been a bug. I really appreciate the effort and I even gave it an upvote. $\endgroup$
    – Nxdhin
    Aug 31, 2020 at 11:15
5
$\begingroup$

Just had this issue, figured out what it was after looking carefully enter image description here

Using your screenshot, it's the button i've drawn an arrow to. disabling that produces what is shown in the screenshot. Fixing it is as simple as re-enabling that button.

$\endgroup$
1
$\begingroup$

I had the same exact issue. Using V2.83.3. Tried a lot of things but could not solve it.

The grid and axis disappeared and modifying Viewport Overlays didn't make a difference - in fact everything look find in the Viewport Overlays settings. The object's vertices, edges and faces all disappeared too, and changing from edit mode to object mode; or changing the Viewport Shading did not get them back.

I noticed that like you, it happened after duplicating part of the object to create a new object. Don't know if this has actually anything to do with the issue.

Finally I ended up creating a new project and importing the objects from the old file. Now everything is fine.

$\endgroup$
0
$\begingroup$

You are in "Wireframe mode" - meaning you just show the outlines of the object. You can switch to "Solid mode" by pressing Z or clicking this icon :

enter image description here

$\endgroup$
1
  • $\begingroup$ Thank you! I realized my question was unclear so I updated the question with more images. $\endgroup$
    – Mana
    Aug 4, 2020 at 15:17
0
$\begingroup$

Since the object is duplicated ,it's internal data may be still linked to the original object.

Make this object unique by making it's properties a "Single User".

This can be done in object mode->object->single user

The rest of the options depends on the state in which your object is in .eg is it Uv unwrapped and textured , animated etc .

enter image description here

$\endgroup$
0
$\begingroup$

If a mesh happens to disappear while you're working with Geometry Nodes, use the Join Geometry node and connect it to input groups as well as any other nodes creating instances/mesh's you would like to not be invisible

$\endgroup$
0
$\begingroup$

I had this issue in Blender 3. I could move in close in edit mode. But in object mode the mesh would disappear when I got close. The problem was I was editing the model when in the UV Editor tab (along the top of the window). Changing back to Layout (also along the top) fixed the problem.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .