1
$\begingroup$

Eevee renders objects in black, while Cycles renders as expected. HDR is present and lights are in the scene. I'm not using any textures. Thanks for any ideas.

Eevee renders with black objects.

Cycles renders as expected.

Q: Why my reflective object is pitch black in eevee?

$\endgroup$
10
  • $\begingroup$ Try enabling screen-space reflections in EEVEE. $\endgroup$ Aug 2, 2020 at 23:48
  • $\begingroup$ Enabling screen-space reflections in eevee did not solve the issue. Thanks. $\endgroup$ Aug 3, 2020 at 0:03
  • $\begingroup$ It is hard to find out what is causing the issue here. Can you provide the file? $\endgroup$ Aug 3, 2020 at 0:28
  • 1
    $\begingroup$ Works correctly for me. check your Graphics Drivers, make sure you have the latest, also try to Delete Blender and install again $\endgroup$
    – Emir
    Aug 3, 2020 at 2:22

2 Answers 2

1
$\begingroup$

Navigate to the Render Properties > Screen space reflections > enable refraction. I hope this works.

$\endgroup$
1
  • $\begingroup$ This didn't work (previously suggested above). Thanks though. $\endgroup$ Aug 4, 2020 at 5:15
1
$\begingroup$

I have discovered that the problem discussed here, as well as other recent rendering posts, may be linked to a video issue related to recent updates.

After duplicating the issues on three computers, all of which meet the video requirements as stated by Blender documentation, I began trying several recent Blender versions. All exhibited rendering issues except Bv2.81.

Thanks to all who helped.

$\endgroup$
1
  • 2
    $\begingroup$ Certain hardware... real issue is: if no one with that graphics card, files a bug report it never get fixed. $\endgroup$
    – brockmann
    Aug 5, 2020 at 1:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .