2
$\begingroup$

This is so frustrating. I'm working with Cycles and I have numerous bottom lit panels in my scene that are sucking up lots of CPU cycles (see pic). In the 3D window (set to 'rendered') they are showing up great. My idea was to bake them (combined), but all I ever got was a black plane. So in desperation I decided I would 'grab' an image of the panel using Render Image (F-12) and save it & then use it directly as a texture node. Guess what!?? F-12 gives me the same black image I was getting when baking the UV map.
screen shot of blender Renders in viewport but not F-12

$\endgroup$
4
$\begingroup$

Okay, I figured out what I was doing wrong. To reduce the clutter in the scene I had turned off visibility of some of the panels (red below). BUT...I did NOT turn off rendering (blue). Inadvertently I had backed the camera behind an invisible plane that had no illumination. When I turned off rendering for the hidden plane things worked fine. So in the preview rendering of the 3d window, what you see is what you get. But in the full render, what you don't see can get you too!

enter image description here

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.