0
$\begingroup$

I am trying to add a simple 2G timing belt to a pair of pulleys. I am using a bezier curve with some modifiers to replicate a belt tooth long it. Things seem to be going ok, but for some reason, there is a twist at the top of the curve and I cannot figure it out. Specifically, the teeth are pointing out at the top and pointing inward (the correct way) along the rest of the curve. Additionally, at the transitions to the top, there is a violent twist? A picture is worth a 1,000 words right:

enter image description here

Can somebody help me out here so that all of the teeth are pointing to the inside along the entire path?

Blender 2.90.0 (2.90.0 2020-07-30) on MacOS 10.15.5

$\endgroup$

1 Answer 1

1
$\begingroup$

Compare to the default setting of curves, twist method was changed. I'm not very sure what's this setting doing. But set it back to Minimum will solve the problem.

enter image description here

Reply to the comment

Select all the points than set the Mean Tilt to 180 degree.

(Actually you can control the rotation of any point one by one. Just choose the points you want to twist than use the Tilt button from the left sidebar. Than click and drag the yellow circle.)

enter image description here

$\endgroup$
3
  • $\begingroup$ Humm. I tried that with no win. I will try it again. I also noticed that the belt is backwards in your screen cap. Is there an easy way to reverse it so the teeth are pointing inside? $\endgroup$ Commented Jul 31, 2020 at 16:52
  • $\begingroup$ Yes there is a way to control the twist. Check the second part in the answer:) $\endgroup$
    – bao007fei
    Commented Jul 31, 2020 at 16:56
  • $\begingroup$ Cool. Will give it a try in a few minutes. Thanks. $\endgroup$ Commented Jul 31, 2020 at 16:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .