5
$\begingroup$

I must be doing something wrong here, but for some reason in blender 2.72/2.72b the anisotropy shader is acting no different from a glossy shader.

Here is a comparison:
enter image description here

As you can see, there is no difference. I have tried all distributions and tangents and adjusting the rotation to no avail.

Here are my nodes: enter image description here

I have not used any anisotropy since 2.72 came out and just opened up a simple scene I have not worked on for a while and noticed that none of the anisotropy is working as before.
Here is the scene I noticed it on:
enter image description here
The second render is the one I want.

Is anisotropy done differently in 2.72, or is this a bug? I am inclined to think this is not a bug since somebody should have reported it by now, and one of the new things in 2.72 is the new Ashikhmin-Shirley distribution.

$\endgroup$
12
  • $\begingroup$ For the anisotropy to be noticeable, there has to be some roughness. Is it possible you could upload before/after renders of the file which broke in 2.72? Or the .blend in question? $\endgroup$
    – gandalf3
    Commented Nov 15, 2014 at 23:51
  • $\begingroup$ @gandalf3 I added the renders of the scene I noticed it on, rendered on 2.71 and 2.72. $\endgroup$
    – PGmath
    Commented Nov 16, 2014 at 0:18
  • $\begingroup$ possible duplicate of Anisotropic material no longer appears radial? $\endgroup$
    – gandalf3
    Commented Nov 16, 2014 at 0:18
  • $\begingroup$ It looks like the tangent is set differently $\endgroup$
    – gandalf3
    Commented Nov 16, 2014 at 0:19
  • 1
    $\begingroup$ @NoviceInDisguiseGraphics the point is that the 2.72 render is showing no anisotropy, even though it has an anisotropic shader with a very high anisotropy value. $\endgroup$
    – PGmath
    Commented Nov 16, 2014 at 2:15

2 Answers 2

6
$\begingroup$

You need some roughness for the anisotropy to be visible.

enter image description here

As I understand it, anisotropic shading simulates the way light reflects off objects with fine grooves like on CD/DVDs or machined cylindrical objects. Without any roughness, the surface is considered smooth (no grooves).

$\endgroup$
1
$\begingroup$

I found the same problem - anisotropic shaders, didn't work with Blender 2.73 on a project which I started on Blender 2.71. There is some kind of a mismatch whit Blender versions. Shaders worked properly when I deleted anisotropic nodes and added them again.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .