2
$\begingroup$

For some reason, when I try to put a texture (picture) on any object, it doesn't work. Here are the steps I took to put a grass texture on a plane:

1: I made a new texture for the plane

2: I set the type to image or movie

3: I opened my Jpeg file

4: I even tried rendering, it won't show up!

Here is a screenshot of when the texture won't load:

enter image description here

Some other texture-related things that won't work for me (even when I follow the exact steps on a video tutorial):

  • Texture painting
  • Cube textures
  • Skydomes (spherical maps)

Any ideas on why this isn't working? Thanks!

$\endgroup$
  • 1
    $\begingroup$ You're almost there, you need to unwrap your model see: blender.stackexchange.com/questions/5915/… (ignore the game engine stuff). $\endgroup$ – stacker Nov 15 '14 at 23:51
  • $\begingroup$ It looks like you added the texture while the camera was active, so the texture isn't actually applied to the plane. Try selecting the plane, then adding the texture. $\endgroup$ – gandalf3 Nov 15 '14 at 23:53
  • $\begingroup$ Actually, I added the camera to the scene after applying the texture. $\endgroup$ – Henry V Nov 15 '14 at 23:59
6
$\begingroup$

You have to unwrap the object and give it a material with the texture for it to show up.

First you have to tell blender how to put a 2D texture on a 3D object by unwrapping it, which means selecting edges where the mesh will be cut to flatten it. This is done by going into edit mode, selecting the edges, hit Ctrl.+E > mark seam, then U > unwrap.

enter image description here

enter image description here

Then you have to give it a material with the texture.

If you are using the cycles render engine this is done by first going to the materials panel of the properties view and clicking New.
enter image description here

Then switch to the node editor and add an image texture node by hitting Shift+A > texture > image texture. Then add a diffuse shader Shift+A > shader > Diffuse BSDF, plug the color output of the image texture into the color input of the diffuse and the BSDF of the diffuse into the BSDF of the material output.
enter image description here

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ He's using blender render not Cycles $\endgroup$ – BlendingJake Nov 16 '14 at 2:14
  • 1
    $\begingroup$ @BlendingJake I know, I just know practically nothing about BI, so if you want to add an answer for BI that would be great! $\endgroup$ – PGmath Nov 16 '14 at 2:28
  • $\begingroup$ @HenryV you still have to give it a material using the texture paint data. $\endgroup$ – PGmath Nov 16 '14 at 15:19
  • $\begingroup$ When I switch to cycles render, it won't let me add the nodes in the node editor. The options are all grayed out. $\endgroup$ – Henry V Nov 16 '14 at 15:30
  • $\begingroup$ @HenryV you may have to click use nodes in the material panel, also make sure you click the new material button. $\endgroup$ – PGmath Nov 16 '14 at 15:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.