6
$\begingroup$

In solid mode with Material or Texture, it is shown fine.

(Shown here) But in the Render mode, everything is pitch black. I have a sun, and the Opacity of the scene is set to 100%.

Shown here)

I am new to using Blender, so I have no idea what is wrong. If you could help, I would appreciate it. If you need more information to help me, I would be glad to give it.

$\endgroup$
8
$\begingroup$

The sun lamp's position, inside the room, doesn't affect where the sun's light is actually emitted from, it only controls the direction. To quote the blender manual:

Sun lamps emit light in a given direction. Their position is not taken into account; they are always located outside of the scene, infinitely far away, and will not result in any distance falloff.

So the light is being cast onto the outside of your room and not getting through the walls to the inside. You can see this by looking at the outside of the room while in 'Rendered' mode of the 3D viewport.

To solve this, you can either disable the 'ceiling' from casting a shadow by changing the 'Ray Visibility' options on the 'Object' tab in the properties space:

enter image description here

Or, change the type of light from sun to something else, like 'Point' or 'Area', whose positions are taken into account. You can also just set any object to emit light, like a plane, by giving it an emission shader.

$\endgroup$
  • $\begingroup$ This worked, but I still want shadows. Is there a way to edit the walls so they are not affected by the lighting? $\endgroup$ – user7831 Nov 15 '14 at 19:29
  • 1
    $\begingroup$ As I said, you can change the sun to a different lamp type. $\endgroup$ – Ray Mairlot Nov 15 '14 at 19:31
2
$\begingroup$

This is a common issue, and without the .blend file, my first guess would be this:

You have clips in the Video Sequence Editor and under Render Settings > Post Processing you have Sequencer checked. Un-check that box:

enter image description here

$\endgroup$
  • 1
    $\begingroup$ Didn't work. And, I do have it stored in a .blend file. $\endgroup$ – user7831 Nov 15 '14 at 18:57
  • $\begingroup$ @MrSquer I believe the reference to the blend file was the fact that we do not have access to your file, to diagnose via screenshots can be guesswork. You can use PasteAll to upload your blend file for us to inspect if you wish. $\endgroup$ – Ray Mairlot Nov 15 '14 at 19:04
  • $\begingroup$ Ok. I added the blend file (pasteall.org/blend/32885) $\endgroup$ – user7831 Nov 15 '14 at 19:09