4
$\begingroup$

I have a model that has animation and I am rendering out to a png sequence. This animation will be used in a web page.

I noticed that there are some items that are showing up in the render that are not part of the model. They are vertical black lines with a dashed line/circle at the top that has a solid circle inside that. They show up in the rendered pngs whether I used material or rendered option in the output view panel.

I've attached an screen grab.

I can't find where these are located in the scene.
I don't know if they are lights or what.

How do I turn them off so they don't render in my png files? screen shot

| improve this question | | | | |
$\endgroup$
  • $\begingroup$ How are you rendering? Are you pushing F12? Those are point lamps, they should not show up in the final render. $\endgroup$ – PGmath Nov 14 '14 at 14:33
  • $\begingroup$ This is an OpenGL render I think @PGmath $\endgroup$ – BlendingJake Nov 14 '14 at 14:33
  • $\begingroup$ @BlendingJake Ah, I kind of speculated that but I never use OpenGL (and have no idea what it does) so I figured someone would correct me! Thanks. $\endgroup$ – PGmath Nov 14 '14 at 14:35
  • $\begingroup$ Do you want to use OpenGL? $\endgroup$ – PGmath Nov 14 '14 at 14:40
5
$\begingroup$

To render just your model without any lights, cameras, empties, or armatures getting in the render; simply turn on Only Render.

The Only Render checkbox is in the Properties panel N under the Display category.
Only Render

| improve this answer | | | | |
$\endgroup$
3
$\begingroup$

You seem to be doing an OpenGL render which basically gives you a quick snapshot of everything in the viewport. Those "items" are Point lamps that light the scene and shouldn't show in a final render that uses correct lighting, aliasing and a world background etc (which I am assuming is what you probably want).

If however you want this quick preview minus the distractions, you can simply hide the lamps by selecting them and pressing H, to unhide them later, use AltH.

To render an image in Blender using the default render engine (Blender Internal) press F12 and to render an animation sequence, refer to How to render an animation as video in Blender?. Both these and the OpenGL render options are available from the Render menu.

enter image description here

| improve this answer | | | | |
$\endgroup$
  • $\begingroup$ If he does want to use an OpenGL render then you can just hide the lamps and you will still get the light in Textured shading, but won't see the lamps. $\endgroup$ – BlendingJake Nov 14 '14 at 14:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.