I created a glass material using the Principled BSDF node. I have a high resolution hdri set as the world environment texture.

However the reflection in the glass material looks very pixelated.

enter image description here

Does anyone know the reason behind this?


1 Answer 1


OK, I think I found the solution. In render settings, go to Indirect Lighting and increase the Cubemap Size. Increasing Filter quality also helps.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .