0
$\begingroup$

When applying two bevel modifiers the smoothing of the first one disappears. Am I doing something wrong or is this a bug?

I am using blender 2.83 and here are my working steps:

  1. Set bevel weight of an edge ring of the default cube to 1
    Cube with bevel weight
  2. Add the following bevel modifier
    First bevel modifier
  3. Turn Auto Smooth on
  4. The result is as expected:
    Result with first modifier
  5. Add another bevel modifier as follows:
    Second bevel modifier
  6. Result: Only those edges that are bevelled by the second modifier get smoothed.
    Result with both modifiers

I would have expected that the smoothing of the large rounded edges is still visible.

Update

Now I know, how to solve the task - thanks to the hints of Jachym Michal :-)

After applying Smooth Shading (RMB - Shade Smooth) to the cube, it looks like this:
Result with Smooth Shading activated

In order to get rid of this shading issue between the flat surface and the rounded corner, that looks like a sharp edge, you need to turn off Harden Normals in the first modifier:
Result after turning off Harden Normals in first modifier

Anyway the Why in my question still remains.

Remaining Questions

  1. When Auto Smooth needs Smooth Shading activated, why does it seem to work properly, when only activating the first modifier?
  2. Why does it break, when turning on the second modifier? Why do I need Smooth Shading in this case?
  3. Why do I get those shading artifacts and why do they disappear, when turning of Harden Normals in the first modifier?

When someone knows the answer, I would appreciate your help. Meanwhile, I will try to understand clearer, how Harden Normals and Auto Smooth are working behind the scenes. Hope, this helps me, to understand the reasons.

$\endgroup$
7
  • $\begingroup$ Hello :). Are you sure the cube has Smooth Shading applied? (RMB > Shade Smooth) $\endgroup$ Jul 28, 2020 at 21:16
  • $\begingroup$ No, it is not. And when I do, I get shading issues at the edge between the flat surface and the rounded corner. (Why) Isn't it enough to turn on autosmooth? (Object Data - Normals - Auto Smooth) $\endgroup$ Jul 28, 2020 at 21:21
  • $\begingroup$ Nope, you need Smooth shading enabled for Autosmooth to work properly :). $\endgroup$ Jul 28, 2020 at 21:22
  • $\begingroup$ Ok. Thank you for this hint. Did not know this. But how do I get rid of the mentioned shading issue? Looks like a sharp edge. $\endgroup$ Jul 28, 2020 at 21:24
  • 1
    $\begingroup$ Yes, that's right! Thank you :-) I probably have to dig deeper into understanding what hardening normals does under the hood. $\endgroup$ Jul 28, 2020 at 21:45

0

You must log in to answer this question.

Browse other questions tagged .