Greetings fellow Blenderers. This is a continuation of the issue first presented here.

I have a very nice 2d plane that has both my PBR cardboard texture as well as the single image with alpha-channel. Now, I'd like to solidify it. Currently, this is the result: My magical no-center cardboard

Now, I completely understand why there is no center. It's just a flat plane and there is no geometry to extrude, per se. My question then becomes: How do I do that? Or, if the answer is (it's too complicated), then how do I fake it?

Thanks in advance for your attention. Hang in there. Like that sun. All smiling and happy. What's his con?..


Okay, I have an idea of a workflow that will work, but I have to get over one really big sticking point:

  1. Keep the existing material because that part works
  2. Go into Illustrator and turn the overall shape of the sun into a single SVG
  3. Import the SVG
  4. Object - Convert to Mesh from Curve
  5. Solidify
  6. Marvel at the truly ghastly default geometry that has been created Behold
  7. Become confused as I can't effectively remesh the resulting geometry so that it has nice, square shaped UV maps.

So yeah, List Item #7 is where I am currently stuck on.

Be great.

Here is a link to my source file. I have pain-stakingly broken out my process flow into individual layer/collections. It should be quite self explanatory once you open it. It's basically a time-lapse of my activities with the shape, trying to make the shape do what I need to eventually receive the texture. I am now amazed at how hard this is.

Update on AM of 7/28 / Thank you for the overnight responses. Specific replies:

  • Susu: I actually did that, but the resulting mesh (using either fill method) was similarly bad looking, though it was still be best result given all the other bad ones I encountered.
  • Moonboots: That's actually what I want to avoid. I have a number of 2d images I'd like to convert to 'cutouts' and manually drawing points takes far too much time and effort.
  • Jachym: Sadly, that doesn't work. When it comes time to apply my texture, I encounter all kinds of display problems. Something about the botched geometry is deforming the results.
  • General Reflection on this: The 2D import behavior is just wretched. I come from a 2D background where SVG's have mostly behave themselves and worked fine in whatever workflow I happen to find them in. But Blender needs to an intervention.
  • Glorious (7/29 Afternoon): I have definitely decimated. Included above is a link to the source file. Thanks for looking! Also, projection mapping didn't work. There's something wonky in the geometry that caused it to look mangled.

Thank you all very much for your contributions.

Current Key Observation: I'm having the darnedest time removing the side geometry from my little sun shape. I can't figure out a proper way to auto-select it without completely butchering the overall geometry. What kills me is that I know I did it last night, but I can't replicate it.

  • 1
    $\begingroup$ I have spent most of this evening fighting with this nightmare geometry. I removed both faces and tried grid fill, followed by regular fill (which was better, but still sucks). I have tried dissolving faces, which does literally nothing to the geometry. I am completely stuck as of this comment. $\endgroup$ Commented Jul 28, 2020 at 3:01
  • $\begingroup$ There is no need to convert to mesh, you can keep your object as curve and extrude in the geometry section for the curve. But if you must convert to mesh, delete all of the faces so that you and fill again with grid fill. $\endgroup$
    – susu
    Commented Jul 28, 2020 at 4:28
  • $\begingroup$ you can also use your image as a blueprint background to draw a mesh with the same shape (star), then project the image as image texture on this mesh $\endgroup$
    – moonboots
    Commented Jul 28, 2020 at 4:54
  • $\begingroup$ Hello :). This may sound like a herecy, but you can keep it as a big n-gon. For your purposes it shouldn't add problems, and you can still extrude it and bevel the edges. $\endgroup$ Commented Jul 28, 2020 at 7:44
  • $\begingroup$ Thanks all very much. I have embedded responses in the original post because there's no character limit. $\endgroup$ Commented Jul 28, 2020 at 14:13

2 Answers 2


I realized that - once again - I'm overthinking this. With more time away, the solution came to me.

In my above question, I identify Step #7 as the issue, but it doesn't have to be. Instead, I realize I should ignore all that goofy geometry. All that matters is I have my ugly extrude with terrible faces.

What I have is that extruded shape set at 0.009 m Z-depth (thin like cardboard). Then I put my 2D plane on it. As long as the material is close to the color of the cardboard (or dominant 2d image color), it will look just fine.

My Current Understanding of Workflow:

  1. Process image to ensure that it has necessary alpha channel. Export a PNG.
  2. Pull image into Illustrator and use the Image Trace option to create a simple outline around the imagery. Export a SVG.
  3. Import Image as Plane; apply additional textures as necessary (if overlaying texture on top of corrugated cardboard texture as I am).
  4. Import SVG as Curves; extrude to needed depth; turn to a mesh.
  5. Place the flat 2D image 'on top of' the 3D mesh that will become the cardboard's faked-depth.
  6. Enter orthographic mode to look at the model head-on. Make final adjustments to ensure the SVG and PNG 'match' locations, as my tests have shown that it won't perfectly match at first. Simply nudge it in ortho and you get your results.

enter image description here

Final note: For whatever reason, when I do this, the 2D image clips into one side of the mesh geometry. Simply adjust the placement (or flip the model over, as I have). This seems to fix it.

Thanks to all of you on my little mini-rollercoaster ride. I will treasure this moment of feeling like I figured something out... because Blender amirite..

  • 1
    $\begingroup$ Having a mesh on top of another is not a good practice. You will run into z-figthing errors (or in your case what you call clipin into one side of the mesh). For situations like this try texturing the object while keeping a single surface. $\endgroup$
    – susu
    Commented Jul 29, 2020 at 20:13
  • $\begingroup$ Thanks. And correct. I have a better solution in the works using single-mesh geometry, but I still see shimmering 'faces'. Going to research z-fighting to see the methods to fix it. $\endgroup$ Commented Jul 29, 2020 at 20:16
  • $\begingroup$ Z-fighting occurs when two surfaces share the same plane, the render engine cannot distinguish which one to render. Even if there is a small gap in between the surfaces, it might turn into an issue depending on the precision of the engine and the clip distances. It is a good practice to avoid having overlapping surfaces. $\endgroup$
    – susu
    Commented Jul 29, 2020 at 20:19
  • $\begingroup$ Yeah, I've encountered this before. And it's an endemic issue when working with SVG's. I can't figure out how to collapse this. Or stop it from happening in the first place. I started with what I thought was a nice, flat, plane. Extruded, turned into nightmare faces. $\endgroup$ Commented Jul 29, 2020 at 20:21
  • $\begingroup$ It doesn't have to be a problem, unless you add objects on top. That additional image as plane will cause problems. Use the image as texture on the curve object directly without any additional geometry. Can you make the original image available (not the blend file)? $\endgroup$
    – susu
    Commented Jul 29, 2020 at 20:31

I've tried this before and ended up using an array modifier to get the desired look - I needed a really small z offset (using constant and not relative offset as the plane has no thickness) and a count of around 64. It doesn't work for side-on views but gives a decent result otherwise.

I also needed to raise the transparent bounces to 64 (each level of the array adds a 'bounce') in the render > light paths panel


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .