1
$\begingroup$

I made models of series of glass chess pieces in Blender. I want to use Compositing to add in a Denoise node, but the Render Layers node does not have a Noisy Image connector, it just has Image, Alpha, and Depth.

In Blender Guru's tutorial on Materials, his Render Layers node has all four of those connectors, plus a bunch of OTHERS as well. How do I fix this?

enter image description here

$\endgroup$
1

1 Answer 1

1
$\begingroup$

You need to enable Denoising Data under Scene Tab > Passes.
Then your compositor will include all needed denoising passes.

Keep in mind, Denoising data are enabled for each render layer separately.

enter image description here

$\endgroup$
5
  • $\begingroup$ I have Denoising Data enabled, but my Render Layers node still only has Image, Alpha, and Depth. There must be something missing from my blender project. $\endgroup$
    – Zach Lund
    Commented Jul 26, 2020 at 23:17
  • 1
    $\begingroup$ Actually, I changed to a different render layer and it had all the connectors, and now I have a snazzy-looking render! $\endgroup$
    – Zach Lund
    Commented Jul 26, 2020 at 23:26
  • $\begingroup$ Hello :). Glad you made it work. Denoising is indeed enabled per render layer. $\endgroup$ Commented Jul 26, 2020 at 23:27
  • 1
    $\begingroup$ @ZachLund -- don't forget to mark this answer as accepted so that jachym gets credit towards master-of-the-universe! $\endgroup$
    – james_t
    Commented Jul 3 at 16:14
  • $\begingroup$ thanks for the support @james_t :) $\endgroup$ Commented Jul 8 at 18:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .