1
$\begingroup$

I'm trying to fix this unexpected behavior of Blender, where smooth shading works everywhere, except the final render. I've read and tried all other Q&A I could find, but nothing really applies. Any ideas?

enter image description here

$\endgroup$
2
  • 1
    $\begingroup$ Are you using a subdivision surface modifier? If so, check to make sure the number of subdivisions are the same for the render as they are for the viewport. $\endgroup$ Jul 23 '20 at 20:10
  • $\begingroup$ No, all subdivisions are already applied. $\endgroup$
    – Slava
    Jul 23 '20 at 22:13
1
$\begingroup$

Verify your normals are correct. Then turn on Normals Auto Smooth. An angle of 30 is good for most stuff.

$\endgroup$
2
  • $\begingroup$ The auto smooth did the trick! Though, I still do not understand why. The chocolate has it off and still renders smooth. $\endgroup$
    – Slava
    Jul 23 '20 at 22:18
  • 1
    $\begingroup$ Spoke too soon. The problem didnt disappear. I ended up adding a new subdivision modifier. $\endgroup$
    – Slava
    Jul 24 '20 at 0:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.