0
$\begingroup$

I have extruded plane (texture is fine on it) edges 1 by 1, and applied a simple brick texture. For some reason nor re-unwrapping nor applying transforms deals with the issue. Normals are correct and making seams does nothing, even splitted or separated faces remain "untexturable".

$\endgroup$
6
  • $\begingroup$ could you please pack your image and share your file? blend-exchange.giantcowfilms.com $\endgroup$ – moonboots Jul 23 '20 at 14:46
  • $\begingroup$ Maybe you need to remove the old UV map. Go to the object data properties tab, got to UV maps, remove the one that's there, and unwrap again. $\endgroup$ – Christopher Bennett Jul 23 '20 at 15:01
  • $\begingroup$ Ooops, I guess it's because of the material. Checker Texture and others work fine. But bricks don't for some reason. $\endgroup$ – Aebis Jul 23 '20 at 16:26
  • $\begingroup$ Checker, and others, are 3D textures, the pattern on the surface is a result of a slice through a field of colors calculated from the XY and Z location of the shading point in whatever space you have set up. The Bricks texture is 2D, it only uses X and Y. Typically, you would give it a UV (XY) map to work with... but there are options, see here, for example $\endgroup$ – Robin Betts Jul 23 '20 at 16:35
  • 3
    $\begingroup$ For making it work with UVs add in a texture coordinate node before the texture and connect the UV to the vector input of the texture $\endgroup$ – Nxdhin2005 Jul 23 '20 at 17:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.