0
$\begingroup$

I'm trying to bind view3d.navigate to middle mouse button so that it's only activated while the buttons is pressed.

I'm having trouble getting it to deactivate. I've tried every option "click", "press", "click drag" for example:

enter image description here

I presumed that didn't work because it needed a command to run on release which would deactivate view3d.navigate. I tried view3d.select as seen below but still no luck: enter image description here

Any hints on what i should try?

Why am I doing this? I'm trying to replicate other 3D design programs. view3d.navigate allows navigating the viewport with wasd keys and moving the mouse.

$\endgroup$
1
  • $\begingroup$ Sorry, I missed that it said 'Walk/Fly' in the screenshot - didn't realise Fly mode's generic name was 'navigate'. Will delete my comments. $\endgroup$ – Ray Mairlot Jul 23 '20 at 14:19
0
$\begingroup$

Go Preferences and see Keymap.

3D View > 3D View (Global) > View Navigation (Walk/Fly)

set to Mouse , Middle Mouse , Press (or Click Drag)

then

3D View > View3D Walk Modal > Confirm

set to Mouse , Middle Mouse , Release

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.