I'm modelling only with textures and vertex collours, since all the extra shading and effects are game-specific and are done within the level editor (not in Blender).

In older versions of Blender, i only used the viewpoints Texture, Solid, Wireframe and Bounding Box. Texture View let me see the model with vertex collours and textures without any extra shading. It showed it exactly, how it would be exported/appear in the game. The Wireframe and Bounding Box viewpoints let me see the model in Vertex Paint without textures and only with vertex collours.

Now in the newer versions of Blender, i can't find any option to see my model only with vertex collours and textures. In solid view options, i can only see either vertex collours or textures, not both at the same time, and there is always extra shading there. Only the Vertex Paint let me see the model with both, but when switching to Object Mode, it's gone.

Is there any way to get the shading view to work, like it did in older Blender versions?


1 Answer 1


You seems to be correct - with Flat type Lightning you can use Texture or Vertex Paint only, if you want use Workbench.

I wanted to use Material type, but it reflects only Viewport Display setup (single RGB Color).

So the only one way I see is use Eevee material. Plug Vertex Color node and Image texture node into Mix RGB node, than directly into Output without any shader.

To see colours untouched you should change Color Management > Standard.

enter image description here


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .