2
$\begingroup$

I am using the newest version of blender (2.83). I modeled and sculpt the head mesh and body mesh separately. And after sculpting, I use boolean modifier combined 2 part of meshes. And then when I try to reenter the sculpt mode, my body part of the mesh becomes yellow. It said my mesh may not have uniform scale. I SOLVED THIS PROBLEM by applying the scale. However, the yellow color of my body mesh does not go off even I close blender and reopen it. Now there is no more warnings or errors showing, however the body mesh is still yellow. I am wondering what I did wrong and how to fix it. Thanks.enter image description here

$\endgroup$
1
  • 1
    $\begingroup$ I fixed it by just using clay strip brush on the edge with dyntopo on. $\endgroup$ Feb 16 at 12:16
8
$\begingroup$

This is the new "Face Sets" feature, I think. It seems to be meant as an extension to the use cases currently covered by hiding and showing faces.

It does not seem to be particularly well documented, or to have much in the way of exposure in the user interface, at this point.

You probably did nothing wrong. I assume that the Boolean modifier probably automatically created two "Face Sets" corresponding to each mesh when they were joined.

To fix this problem, you can open the new "Face Sets" menu in the 3D view's Sculpt Mode header. The very last option says "Randomize Colors", and will randomly reassign each region of your mesh a new colour. You can repeat this operation until the colours of your mesh are no longer yellow. (I hope you like purple, red, blue, or green.)

Alternatively, you could also try one of the options under "Init Face Sets", or using the "Draw Face Sets" sculpting brush and holding CTRL from one area to paint over the rest of your mesh.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.