1
$\begingroup$

Relearning blender, I notice when I render my image, the shadow looks pointy.. the mesh is very smooth so I don't know whats causing this. The same thing happens in Eevee. Anyone know what might be causing it?

enter image description here

I've tried playing around with the lighting strength and trying different angles but still get the same issue. I'm using just a default point light, what is wrong?

$\endgroup$
  • $\begingroup$ @JachymMichal Just edited it, hopefully you can see it better $\endgroup$ – cgperfect Jul 21 at 16:46
  • 1
    $\begingroup$ @JachymMichal, he's talking about pointy noise, not the shape of the shadow. $\endgroup$ – Sanbaldo Jul 21 at 17:15
2
$\begingroup$

The way Cycles works is by creating a rough approximation of the final image and then cleaning up the noise over time. The more samples you set in Cycles, the more time it has to clean up the scene (but the longer it takes to finish rendering). The reason it's not cleaning up anymore for you is that you don't have the samples set high enough. You can change how many samples you use in Properties -> Render -> Samples. There are two settings, one for the viewport and one for the final render. You typically want the final render to have more samples than the viewport. If the image is too noisy, you can increase the samples, and if it takes too long, you can decrease the samples.

Render Samples Setting

If you're not sure how many samples to set it to, you can set the viewport samples to 0 (aka infinity) and wait until the image clears up (and you can't move around in the scene while it's clearing up). Once it's clear enough, you can look in the top left where it says, "Path Tracing Samples", and whatever number that's at, you can set the viewport or final render to that. Note, it's okay if you have the viewport samples set to something low enough that it still is a little noisy. As long as the final render samples are high enough, the final render will look good.

Render Samples Example (In this scene, 38 samples is good enough for the viewport, but I'll probably want the final render to be set for something like 64 or 128 just to make it nice and clear [if you look closely at the shadows, you can see a little noise])

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ for the viewport I've seen some people setting the number of samples very high, so the viewport continue updating itself getting better and better) $\endgroup$ – Sanbaldo Jul 21 at 17:22
  • 2
    $\begingroup$ @Sanbaldo Honestly, that makes sense, though you can just set the viewport samples to 0 to get the same results. $\endgroup$ – ElliotThomas Jul 21 at 18:44
  • $\begingroup$ great feature! thanks $\endgroup$ – Sanbaldo Jul 22 at 7:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.