0
$\begingroup$

This is a scene of a Camaro in an unlit environment. It's meant to be pitch-black until the keyframed emission material turns on. As you can see from the first image, the material shows in material view, but in rendered view (and in an actual render) the other headlight doesn't show. I tried it in eevee and it works fine. Any ideas on why this would happen? I'm not sure I changed anything significant between when it did work and now.

I am using Blender v2.83.2.

Below I also provided some images of settings I thought were important to this question. Let me know if there's any other information I should provide.

Side by side of rendered and material view

Cycles render settings

Material Settings

Edit mode showing material assignment

$\endgroup$
  • 2
    $\begingroup$ I guess, you mirrored one half of the car during the modeling process, right? Did you check if all the normals are pointing outwards on both halves of the car? $\endgroup$ – haarigertroll Jul 21 at 7:25
  • $\begingroup$ @haarigertroll the model is a downloaded asset, not mirrored. $\endgroup$ – Amir Abbas Jul 21 at 18:55
0
$\begingroup$

It must have been a glitch with Cycles. The car is inside a warehouse environment, with two other cubes acting as doors to block all sunlight and slowly move to let sunlight in. I just had to hide the doors and unhide them, and it somehow reset the lighting. In the future if anyone comes across this, just change some stuff up in your scene that affect lighting, I guess. Someone else also said they had the same issue, and when they created a new Blender file it worked. If you don't have too much to lose, that is also an option.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.