0
$\begingroup$

I have some hair that I've created in one of my projects. At some point, somewhere, I must have pressed a hotkey by accident, because now none of the hair is rendering in Cycles. It fails to appear in both Cycles rendered viewport or in a full Cycles render. The hair does show up in Eevee and every other viewport mode.

Potentially useful info:

  • Just as a test, I started another project and was able to get hair particles to render in cycles. I also created another object in this file and tried to put some hair on it. The hair on the new object also didn't render. So it's particular to this blend file and seems to be some sort of global setting.
  • Note that there are actually three hair particle systems in this file (eyebrows, upper lashes, lower lashes), and none of them are showing up. So I don't think it's a setting specific to the particle system.
  • Nonetheless... in the particle system render settings for all three systems, I have "Render as" set to "Path", so that's not the issue. Also, there is a material applied to the hair, but the problem is not solved by deleting it.
  • None of the "Hair" options in the Cycles render settings have any effect.

I've googled this extensively, and there's apparently a setting called "ray invisibility" that you can turn on or off, but all of information about it I could find are from earlier versions of blender and I can't find this setting anywhere in 2.83. I don't know if that's the problem, but somebody please tell me where to find this setting so I can test it.

Please help, this problem has ground my project to a halt and I feel like I'm losing my mind here.enter image description here enter image description here

$\endgroup$
0
$\begingroup$

So I ultimately downloaded the experimental Blender 2.9 and it fixed the issue. I guess that means it's a bug.

EDIT: Another fix, should this happen to any of you, is to create a new project and append all of the assets from the original project. The hair will then render properly in the new project.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.