0
$\begingroup$

I'm connecting the bump Node into the normals of the principle BSDF shader , but it's not appearing on my texture. A user already helped me set up the nodes. But I'd like to add a bump to it as well.

Thank you.

enter image description here

$\endgroup$
3
  • 2
    $\begingroup$ Connect the noise output to the height input of the bump node $\endgroup$
    – Gorgious
    Commented Jul 20, 2020 at 15:42
  • $\begingroup$ I connected the noise output to the height of the bump node, but now I'm getting a non transparency. The PNG file has a background to it. ibb.co/QHtTC7P $\endgroup$ Commented Jul 20, 2020 at 15:55
  • $\begingroup$ Plug the alpha output of the Image texture node into the alpha of the principled bsdf $\endgroup$
    – Gorgious
    Commented Jul 20, 2020 at 20:38

2 Answers 2

2
$\begingroup$

Sorry, when I posted an image before, I forgot to connect the bump node. It really shouldn't change that much though, The only thing I can think is the subsurface color is interfering. I'll post the setup once again (without subsurface color) to show the setup that works for me. You can add subsurface after and see if that's the problem (if you also used 2 materials, maybe you added it to one and not the other). Once again, I used 2 materials, one for the block, and one for the wolf face. This can be done all in one, but, first things first. Have a look:

Wolf1

Wolf2

$\endgroup$
1
  • $\begingroup$ This is the answer I was looking for. $\endgroup$ Commented Jul 21, 2020 at 9:27
2
$\begingroup$

Connect a texture to the bump. Either a normal map into the normal input or a texture (such as noise) into the height input. Then control the strength with the distance and the strength values.

enter image description here

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .