0
$\begingroup$

I'm modeling a house, and trying to get realistic glass in a plane glass. I've seen a lot of tutorials but they used spheres and Suzanne applied the material. The result I want is light in the image (we have no reflection) where the main light shadows hit the glass, and them it's more transparent, where in the other areas it's more reflective. I still want to see the artificial light inside the room. I've tried different values of IOR, and I'm using AlphaBlend and AlphaHash in glass material. Glass thickness = 1cm

World nodes

Glass nodes

The glass I want

The glass I have :(

$\endgroup$
3
  • $\begingroup$ Increase the ior of the Fresnel of the glass to 40.That will solve it.. $\endgroup$
    – Nxdhin2005
    Jul 20, 2020 at 13:29
  • $\begingroup$ Related: ArchViz Glass for quick renders in Cycles? $\endgroup$ Jul 20, 2020 at 14:11
  • $\begingroup$ I did, but increasing fresnel only made the glass more transparent... $\endgroup$
    – Jefferson
    Jul 20, 2020 at 18:28

1 Answer 1

1
$\begingroup$

Here, try this setup. I'm posting pictures of the same setup in both EEVEE and Cycles so you can see that the shadow is in the same place, just much more pronounced in eevee.

Here is EEVEE:

EEVEEGlass

Now the same thing in Cycles:

CyclesGlass

You can see the shadow is there, just a bit muted. I could have played with the settings a bit more. I had to up the brightness of the spot light to make it stand out properly, and I have a rather bright light inside the building, which could be adjusted to make things look better. For the record, The glass in my picture is a separate object (plane), extruded to be 0.01m thick. Here is the final render (low sample - not de-noised). I think it at least shows the shadow, reflection, refraction and specular lighting. To make it look more like "clear glass", you can try increasing the fresnel value, or adjust the slider on the mix shader controlling the mix with the Transparent BSDF, or both. See what works best.

Rendered image (Cycles):

GlassRender

$\endgroup$
3
  • $\begingroup$ I tried the your glass material, and I can see the shadow in the glass, but in my model it'a not more transparent in these areas $\endgroup$
    – Jefferson
    Jul 20, 2020 at 18:30
  • $\begingroup$ I'm sharing the link of the .blend file drive.google.com/file/d/1ZyTKKGQFn1FzBb26CLJ1WBnUbeOpZzO2/… $\endgroup$
    – Jefferson
    Jul 20, 2020 at 19:15
  • $\begingroup$ Try replacing the Diffuse BSDF in my graph with a Glass BSDF $\endgroup$ Jul 20, 2020 at 20:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.