0
$\begingroup$

I have commissioned a model that was textured using UDIM tiles, which Blender supports. However adding the image texture node and setting it UDIM tile, or dragging the image in where Blender automatically sets it to be a UDIM tile, is not importing the UDIM tiles properly. The UDIM's look to be exported correctly, with the Base Colour folder with the name and 1001, 1002, 1003, and 1004...according to the tutorials, I need only bring the first image in and Blender knows to look for the others.

This isn't happening however...only the first image seems to be affecting the material for the mesh, the other tile are not being imported. We've checked triple checked and checked again, the file protocol is right. UDIM tiles not working

There must be something that we are missing...everything looks right, but except the textures...

Can anyone help?

$\endgroup$
0
$\begingroup$

It turns out it was an issue from the creator's end. I will post more details about what went wrong when I find out, in case this happens to anyone else.

$\endgroup$
0
$\begingroup$

The issue was partly from the creators side, and partly how Blender manages UDIM tiles, which is clearly still in its early days. It was required to go to these steps:

  • Make sure Blender project is saved
  • Go to UV Editor
  • Hit N for side panel
  • Where it says Image>Source, change "single image" to UDIM tile.
  • Click the "plus" sign for create new image for as many UDIM tiles as you have - in my case it was 4. You should have in your list 1001, 1002, 1003, 1004 etc.
  • The UDIMs will now appear correctly.

HOWEVER:

You ALSO need to do this for all the other textures. So if you have only 1 UDIM tile (which is much more likely) but the normals, roughness, metallic textures are all not importing, you need may need to do this. And of course if you ahve more than one tile, then you need to add to the UV editor as many tiles as you have.

After that, it all works perfectly, and you only need the one Material for all of your meshes for that model. I hope this helps someone.

Side Panel (shortcut "N") in UV Editor

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.